summaryrefslogtreecommitdiff
path: root/sys-boot/grub/grub-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
commit0bc41c955151f7b962f67f03e18e580620f91bd6 (patch)
tree834073a4e0c66ae35e5b891a763832075aad475f /sys-boot/grub/grub-9999.ebuild
parente54e6bf2ec8cc0fb912bffefee5b3d22cd3fcd9c (diff)
gentoo auto-resync : 17:01:2023 - 17:55:17
Diffstat (limited to 'sys-boot/grub/grub-9999.ebuild')
-rw-r--r--sys-boot/grub/grub-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 3f9fdfc128e2..359da219ea62 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -5,13 +5,13 @@ EAPI=7
# This ebuild uses 3 special global variables:
# GRUB_BOOTSTRAP: Depend on python and invoke bootstrap (gnulib).
-# GRUB_AUTOGEN: Depend on python and invoke the autogen.sh.
+# GRUB_AUTOGEN: Depend on python and invoke autogen.sh.
# GRUB_AUTORECONF: Inherit autotools and invoke eautoreconf.
#
# When applying patches:
# If gnulib is updated, set GRUB_BOOTSTRAP=1
-# If *.def is updated, set GRUB_AUTOGEN=1
-# If gnulib, *.def, or any autotools files are updated, set GRUB_AUTORECONF=1
+# If gentpl.py or *.def is updated, set GRUB_AUTOGEN=1
+# If gnulib, gentpl.py, *.def, or any autotools files are updated, set GRUB_AUTORECONF=1
#
# If any of the above applies to a user patch, the user should set the
# corresponding variable in make.conf or the environment.
@@ -156,8 +156,6 @@ src_unpack() {
src_prepare() {
default
- sed -i -e /autoreconf/d autogen.sh || die
-
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
python_setup
else
@@ -168,7 +166,7 @@ src_prepare() {
eautopoint --force
AUTOPOINT=: AUTORECONF=: ./bootstrap || die
elif [[ -n ${GRUB_AUTOGEN} ]]; then
- ./autogen.sh || die
+ FROM_BOOTSTRAP=1 ./autogen.sh || die
fi
if [[ -n ${GRUB_AUTORECONF} ]]; then
@@ -292,7 +290,7 @@ src_install() {
einstalldocs
insinto /etc/default
- newins "${FILESDIR}"/grub.default-3 grub
+ newins "${FILESDIR}"/grub.default-4 grub
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub