summaryrefslogtreecommitdiff
path: root/sys-boot/lilo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
commit7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (patch)
treed4b1fc995691d4c2cde45fc9d9875e80e85fda73 /sys-boot/lilo
parentcc4bdc5d184af171efd67a1b32de966071ee18d3 (diff)
gentoo auto-resync : 02:02:2024 - 11:45:20
Diffstat (limited to 'sys-boot/lilo')
-rw-r--r--sys-boot/lilo/Manifest2
-rw-r--r--sys-boot/lilo/lilo-24.2-r1.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/sys-boot/lilo/Manifest b/sys-boot/lilo/Manifest
index c3383af809f6..681ad2d8e090 100644
--- a/sys-boot/lilo/Manifest
+++ b/sys-boot/lilo/Manifest
@@ -5,5 +5,5 @@ AUX lilo-24.x-fix-gcc-10.patch 1020 BLAKE2B d434248d3f4ed4d591ada4d507e5ab804862
AUX lilo.conf 1613 BLAKE2B 0d1f1a67f270e6d0cfac6d6dbdd7468bee3405b455ab20d9095c3f63ffd608323cddcae13550799bb7cc8eb086069c38df65c501b9a3083f01c6b50383d40776 SHA512 27f544fe382f8b126b4bc45a2c60474c0bfd8ddacd7997af67c7263b98ad2eef856b687e9f36232db4cd5625be301a284f208d833aefccd04a01268993007d57
DIST dolilo-0.6.tar.bz2 3817 BLAKE2B 35c41f5eac8e02d4381db517a9b230d037da184f9ae409bc76307e689ad6b82928ea3794db54c3137afe6c770db86ba0cde78c33d89e775ddea464905070bfd6 SHA512 1b59ea5f2e2ac52d62635c9f7d5fb5b2aff6757e6ea6c0950480d8a11832b872115907abe6d8fb3fa5436e2e8971d9a1dda103dc6a15db6fc310c8f4730ab936
DIST lilo-24.2.tar.gz 777400 BLAKE2B 71c74235d5df10eed65b67dc1ce2af21163651c752d799da419077025304abf9352535a70f3fb60d086609d8a1c25bf394e29453c338ab022cb2be3cb21af75f SHA512 4437cae21345f483194a5dc95f686f3f3cb2beec78faae3fba959db25eae29fe2c56732e055c05f1d101682c5d442cdc9561fae8074f61f5537dde0413204c54
-EBUILD lilo-24.2-r1.ebuild 4435 BLAKE2B 3d99bccd1790d3c0713d738620ecd8ca728da6194c68b693e99362329e835a70fdbf98a4bd99a5df45589fff7b65f842ccdadc494d6df6c1f488fe1790822659 SHA512 a0af5d45cdc470cfa9275012567646a99da76df7319e94df0252fe3537cf487fa0cb628615d9d8fa1d5b219d9105de5b0cc7824ed9d7b3536b4d74e6f729615f
+EBUILD lilo-24.2-r1.ebuild 4574 BLAKE2B 450148d9e105be2ab67dd07a8016fa4cc6780cc416d8f011538c1a7f14eab48a7328bb7b4c23e9798844fed0f5efab1dae90059c1f5c90d3be1634b79cd49d03 SHA512 f4d277a3f38082b0a593d1d6b303a48bf3acec857f7c47c3e8bd1ef8cbdcec6c4a676dc8c1561d8661e32a09f441ee2c20122df9360b03f3aec48f1bd900fb5f
MISC metadata.xml 475 BLAKE2B e197c079a1bc1a024d6a9a1b1195459bbaeafd92a901d71c1f13f21d9e50d56fa330d40af270c0b6f6242d09efa46e4a2e859731bae18c0f0d7d9babcf2ce94a SHA512 c5928a78231fd60410ee2ff2468bf775f9077cd45d2bd5939ae3e0d92d05fa2bdfabdba362f4ec9e004429243e843a4ae6289be1506c4412a0a29218f2992ea5
diff --git a/sys-boot/lilo/lilo-24.2-r1.ebuild b/sys-boot/lilo/lilo-24.2-r1.ebuild
index 66040236a6d6..a1e7a24913fd 100644
--- a/sys-boot/lilo/lilo-24.2-r1.ebuild
+++ b/sys-boot/lilo/lilo-24.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic optfeature toolchain-funcs
DOLILO_V="0.6"
IUSE="static minimal pxeserial device-mapper"
@@ -184,4 +184,7 @@ pkg_postinst() {
einfo "edit /etc/conf.d/dolilo to harness its full potential."
echo
fi
+
+ optfeature "automatically updating lilo's configuration on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}