summaryrefslogtreecommitdiff
path: root/sys-boot/mokutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-03 04:43:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-03 04:43:49 +0100
commit9b22dab88308071d43d47cd078b37903900f47d3 (patch)
tree67e9a0a10dcdbe72770cc89ba63028a4a8efd711 /sys-boot/mokutil
parentf354cd2612137255e64a82b6578696697b0415b4 (diff)
gentoo auto-resync : 03:10:2024 - 04:43:49
Diffstat (limited to 'sys-boot/mokutil')
-rw-r--r--sys-boot/mokutil/Manifest2
-rw-r--r--sys-boot/mokutil/mokutil-0.7.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-boot/mokutil/Manifest b/sys-boot/mokutil/Manifest
index 516d51ec3f97..4bf1afa91646 100644
--- a/sys-boot/mokutil/Manifest
+++ b/sys-boot/mokutil/Manifest
@@ -1,4 +1,6 @@
AUX mokutil-0.6.0-conflict.patch 1098 BLAKE2B 304be1d9237ff04915f5421680da94ba0a5462d447ffb6b5d4af46ef63ce87056ba58be4b60d0aca914186bed62c95215fa3c18fb996349d92c3a3b36dcc2c1a SHA512 1ace1309e3010d45769248fea70a92f9273fdb4658c3d7575cee4cc9c85d661108f4abde51a90370434eb66994fbd204113ba02c54b5170706db415ac629747b
DIST mokutil-0.6.0.tar.gz 38047 BLAKE2B f2307807c700091f1e5a783b3ad8e7b3eaa17e05580b2c24fd0e92433c6b9bedfb51e9eb2d5d1c71448623b12b6667a573dd51ed03fc738aaf9815083e118ca0 SHA512 11a9d172dba4fbb674e58e5d82cb1dc65a80cff844c0eaebd106b4d4608b24a8207e0cfabf36fe1eedb67f68a8a18db2136c7b62aa3230ac104615e8284dbd7d
+DIST mokutil-0.7.2.tar.gz 39226 BLAKE2B e3b639070e03a41c9bbf45fd7c95656b1e149a1bf43fdc15396853303cf776b9b8279c48049ff5ec1c4397cb15c58d69c618b884864a7941ad747567963cd491 SHA512 cdab37f86191c009b8264f065c3ca8ca051d8c1366191dca4c142d4146a0f7b7614cb17e53b6a8ca6fde0462bc113d4a1a751673b755eea0b3ed6e90da507f5a
EBUILD mokutil-0.6.0.ebuild 616 BLAKE2B 5c3643ea7f1c88cbd85b3edb416df568716fd197884874d08b90c6ac4c727c8103ce499f8a51a09fc4e701b25193120f53358c10575f2dbb10e76eef4e7de38e SHA512 3b7e7dcf26dbabae49cb2fe4fb2af4d2de69f5f890e071de81a6a17720506fd34ab1b22345faa23fef42e9ec85b8c1aac48a8f07deaa77fa1acd03a86a646054
+EBUILD mokutil-0.7.2.ebuild 560 BLAKE2B 2bf6fed4b5efdb5c48b8a9fa7f42130a9c831919d21714d80fa68286d8e5ad9b711eb78be1275e8f1fdffdbf6b48416987f7256c53a2850474d3ddba1a356849 SHA512 acc0e78a10bd18c68a9b31263205bf64e6d514566b8fda55990b2b3455fca813381c6ba8210bb991ef54b0d70d58e20d7f10aff3bae42a4cd3341fe9118eaf03
MISC metadata.xml 324 BLAKE2B 803a9f3dfc400fd7358eb385dbdcd68c75cb26fbaf90ceb26ff41c7eef6ed3c34cb2d1418e2baa2c3b479615d473583fa7aa6b88544b6b1399cdd1e304ad3cbc SHA512 c0d24dc6c45f5d6f4d6d2b01b14a79376f4adf5847348bd9e5cdde20af1fe88ec9681bc6fd88126febf749dc0822d3b78bd2babcfa80abbbff3d1580aafc530e
diff --git a/sys-boot/mokutil/mokutil-0.7.2.ebuild b/sys-boot/mokutil/mokutil-0.7.2.ebuild
new file mode 100644
index 000000000000..4c6f2d379159
--- /dev/null
+++ b/sys-boot/mokutil/mokutil-0.7.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="The utility to manipulate machines owner keys which managed in shim"
+HOMEPAGE="https://github.com/lcp/mokutil"
+SRC_URI="https://github.com/lcp/mokutil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:=
+ sys-apps/keyutils:=
+ sys-libs/efivar:=
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}