summaryrefslogtreecommitdiff
path: root/sys-boot/palo/palo-2.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
commitbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (patch)
treee255548891f2188ab2594eedde60d6f426ef24ed /sys-boot/palo/palo-2.24.ebuild
parentdef28ad1de5a6853465d7ff8f626cda6a774cd9e (diff)
gentoo auto-resync : 02:06:2023 - 09:28:30
Diffstat (limited to 'sys-boot/palo/palo-2.24.ebuild')
-rw-r--r--sys-boot/palo/palo-2.24.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-2.24.ebuild b/sys-boot/palo/palo-2.24.ebuild
new file mode 100644
index 000000000000..6eae2c2820e0
--- /dev/null
+++ b/sys-boot/palo/palo-2.24.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/ https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}