summaryrefslogtreecommitdiff
path: root/sys-boot/tboot/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sys-boot/tboot/files
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sys-boot/tboot/files')
-rw-r--r--sys-boot/tboot/files/tboot-1.10.3-disable-Werror.patch12
-rw-r--r--sys-boot/tboot/files/tboot-1.10.3-disable-strip.patch14
-rw-r--r--sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch12
-rw-r--r--sys-boot/tboot/files/tboot-1.9.11-genkernel-path.patch62
4 files changed, 38 insertions, 62 deletions
diff --git a/sys-boot/tboot/files/tboot-1.10.3-disable-Werror.patch b/sys-boot/tboot/files/tboot-1.10.3-disable-Werror.patch
new file mode 100644
index 000000000000..5285227713ad
--- /dev/null
+++ b/sys-boot/tboot/files/tboot-1.10.3-disable-Werror.patch
@@ -0,0 +1,12 @@
+diff -r 5a30b6b09e77 Config.mk
+--- a/Config.mk Fri Dec 10 15:35:42 2021 +0100
++++ b/Config.mk Sun Dec 12 14:53:57 2021 -0600
+@@ -39,7 +39,7 @@
+ /dev/null 2>&1`"; then echo "$(2)"; else echo "$(3)"; fi ;)
+
+
+-CFLAGS_WARN = -Wall -Wformat-security -Werror -Wstrict-prototypes \
++CFLAGS_WARN = -Wall -Wformat-security -Wstrict-prototypes \
+ -Wextra -Winit-self -Wswitch-default -Wunused-parameter \
+ -Wwrite-strings \
+ $(call cc-option,$(CC),-Wlogical-op,) \
diff --git a/sys-boot/tboot/files/tboot-1.10.3-disable-strip.patch b/sys-boot/tboot/files/tboot-1.10.3-disable-strip.patch
new file mode 100644
index 000000000000..c7a7fd04c7b5
--- /dev/null
+++ b/sys-boot/tboot/files/tboot-1.10.3-disable-strip.patch
@@ -0,0 +1,14 @@
+diff -r 5a30b6b09e77 Config.mk
+--- a/Config.mk Fri Dec 10 15:35:42 2021 +0100
++++ b/Config.mk Sun Dec 12 14:52:19 2021 -0600
+@@ -56,10 +56,6 @@
+ OBJCOPY ?= objcopy
+ OBJDUMP ?= objdump
+
+-ifeq ($(debug),n)
+-INSTALL_STRIP ?= -s
+-endif
+-
+ INSTALL ?= install
+ INSTALL_DIR = $(INSTALL) -d -m0755 -p
+ INSTALL_DATA = $(INSTALL) -m0644 -p
diff --git a/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch b/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch
new file mode 100644
index 000000000000..83adeda6d5ac
--- /dev/null
+++ b/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch
@@ -0,0 +1,12 @@
+diff -r 5a30b6b09e77 tboot/Makefile
+--- a/tboot/Makefile Fri Dec 10 15:35:42 2021 +0100
++++ b/tboot/Makefile Mon Dec 20 13:06:09 2021 -0600
+@@ -34,7 +34,7 @@
+ TARGET_LDS := $(CURDIR)/common/tboot.lds
+
+ $(TARGET).strip : $(TARGET)
+- strip $< -o $@
++ $(STRIP) $< -o $@
+
+ $(TARGET).gz : $(TARGET).strip
+ gzip -n -f -9 < $< > $@
diff --git a/sys-boot/tboot/files/tboot-1.9.11-genkernel-path.patch b/sys-boot/tboot/files/tboot-1.9.11-genkernel-path.patch
deleted file mode 100644
index b2459816068b..000000000000
--- a/sys-boot/tboot/files/tboot-1.9.11-genkernel-path.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -r 9998b2fb83fd tboot/20_linux_tboot
---- a/tboot/20_linux_tboot Wed Apr 10 11:47:06 2019 +0200
-+++ b/tboot/20_linux_tboot Tue Jul 23 22:42:00 2019 -0500
-@@ -173,7 +173,16 @@
- EOF
- }
-
--linux_list=`for i in /boot/vmlinu[xz]-* /vmlinu[xz]-* ; do
-+machine=`uname -m`
-+case "$machine" in
-+ i?86) GENKERNEL_ARCH="x86" ;;
-+ mips|mips64) GENKERNEL_ARCH="mips" ;;
-+ mipsel|mips64el) GENKERNEL_ARCH="mipsel" ;;
-+ arm*) GENKERNEL_ARCH="arm" ;;
-+ *) GENKERNEL_ARCH="$machine" ;;
-+esac
-+
-+linux_list=`for i in /boot/vmlinu[xz]-* /vmlinu[xz]-* /boot/kernel-*; do
- basename=$(basename $i)
- version=$(echo $basename | sed -e "s,^[^0-9]*-,,g")
- if grub_file_is_not_garbage "$i" && grep -qx "CONFIG_INTEL_TXT=y" /boot/config-${version} 2> /dev/null ; then echo -n "$i " ; fi
-@@ -219,7 +228,9 @@
- "initrd.img-${alt_version}" "initrd-${alt_version}.img" \
- "initrd-${alt_version}" "initramfs-${alt_version}.img" \
- "initramfs-genkernel-${version}" \
-- "initramfs-genkernel-${alt_version}"; do
-+ "initramfs-genkernel-${alt_version}" \
-+ "initramfs-genkernel-${GENKERNEL_ARCH}-${version}" \
-+ "initramfs-genkernel-${GENKERNEL_ARCH}-${alt_version}"; do
- if test -e "${dirname}/${i}" ; then
- initrd="$i"
- break
-diff -r 9998b2fb83fd tboot/20_linux_xen_tboot
---- a/tboot/20_linux_xen_tboot Wed Apr 10 11:47:06 2019 +0200
-+++ b/tboot/20_linux_xen_tboot Tue Jul 23 22:42:00 2019 -0500
-@@ -167,6 +167,15 @@
- EOF
- }
-
-+machine=`uname -m`
-+case "$machine" in
-+ i?86) GENKERNEL_ARCH="x86" ;;
-+ mips|mips64) GENKERNEL_ARCH="mips" ;;
-+ mipsel|mips64el) GENKERNEL_ARCH="mipsel" ;;
-+ arm*) GENKERNEL_ARCH="arm" ;;
-+ *) GENKERNEL_ARCH="$machine" ;;
-+esac
-+
- linux_list=`for i in /boot/vmlinu[xz]-* /vmlinu[xz]-* /boot/kernel-*; do
- if grub_file_is_not_garbage "$i"; then
- basename=$(basename $i)
-@@ -234,7 +243,9 @@
- "initrd-${version}" "initrd.img-${alt_version}" \
- "initrd-${alt_version}.img" "initrd-${alt_version}" \
- "initramfs-genkernel-${version}" \
-- "initramfs-genkernel-${alt_version}" ; do
-+ "initramfs-genkernel-${alt_version}" \
-+ "initramfs-genkernel-${GENKERNEL_ARCH}-${version}" \
-+ "initramfs-genkernel-${GENKERNEL_ARCH}-${alt_version}"; do
- if test -e "${dirname}/${i}" ; then
- initrd="$i"
- break