summaryrefslogtreecommitdiff
path: root/sys-boot/unetbootin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-boot/unetbootin
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-boot/unetbootin')
-rw-r--r--sys-boot/unetbootin/Manifest2
-rw-r--r--sys-boot/unetbootin/unetbootin-702.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index 67f0b8187360..c331dacba913 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -1,4 +1,6 @@
AUX unetbootin-675-desktop.patch 737 BLAKE2B c449895c150513ca0df22d1648d8d4a01a1c27a0afe9875631b9b19ae6680b39edbfc50a0344adaf434db28bb02bcd34b5756faf07fe1438d471d24902209e61 SHA512 fef904d63a93fc4ddbee82e097645cb090563d2448872462bba9a6a971da47b595bd63fa4fafd0f3c7630b794f2e12591435d1a413f7b8c0bfdd0664963e6335
DIST unetbootin-700.tar.gz 16694955 BLAKE2B d8c00b56c5ae2daac696b62ef207c62dc91f67699c8823e2a751eff536d03fd0a50a931e9a4598b05d99be968b7e895ab521f605b4e0080d591a34c9e67f685e SHA512 0d1b23dddf0e0e3eca81f8ef07fe375f0867ee3fa631c3a3cfe33a846b8d704b36e0efe4c947d7c68e5c1bff370ba87c34aa52c5bf8fc414cd89777f9f1858b7
+DIST unetbootin-702.tar.gz 16694922 BLAKE2B 4205b8e5a64ecbd95e3b5f3492a01333691768547e6dbe5f954982dfa35d0794bbf8b4bc7002ff62b13675e9beaa25caf83d999489c9fabd36acc8df171e5d05 SHA512 4794a1c5481a082ab589c213156501697a9c2262102e1d0ca882a6c757d388d0ca768ed9acff29aac89f17a4842a93ab25ecbfceaafa27ea91d578e16fabe153
EBUILD unetbootin-700.ebuild 2125 BLAKE2B 30803cbc7b7283a6ef70a7586ee20a68a18235207a034919ed59bec6437037f0d67be2de954e828453bbab12fea31a9896751598df7ad004bfe67d27ccefd64b SHA512 f7ad94b5ea04fb75d7973e0dccf40bfdf9bcb557cac6c39e4a1a5bccbe1999edc52f53f1c46c0034fb2d2d6a490c86e48db79abf9cf535cdd6788b83e3a85435
+EBUILD unetbootin-702.ebuild 2127 BLAKE2B aecb663caeafb58db6f2634b15e019ea8ba71c7e022624974044ba3f651efcd0d29502d7e5572a89ed03f0cbdf35fda589157e0419f67afac6fe65ae37aad34f SHA512 6285b600e20843f8904808243a2815a724ff37827a1d58efa42fd2a21fff2c6edfa79986037a865254560fd858e9c1521d16a87278615b3590d86d0b0cec759c
MISC metadata.xml 309 BLAKE2B d1fcabbcd01d4cd4bfc01331588584843341e98a4dbd1bf3ebcb419d75063f3ae5dbf3fb13f7cc10be39507f338b10238c9185370bb90afe37fe8e145ac92b33 SHA512 855572f6bd3782b646d8b0ea2d908c0e7294284844fc05d343542577e9757358a9cb475fd2d79ba61e7ceb43ec810458e2ec47701580d2b9c154cd84efaa4cc1
diff --git a/sys-boot/unetbootin/unetbootin-702.ebuild b/sys-boot/unetbootin/unetbootin-702.ebuild
new file mode 100644
index 000000000000..d42e3c699212
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-702.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic qmake-utils xdg-utils toolchain-funcs
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="https://github.com/unetbootin/unetbootin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-675-desktop.patch )
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ append-cflags -DNOSTATIC
+ append-cxxflags -DNOSTATIC
+}
+
+src_configure() {
+ export QMAKE_CXX="$(tc-getCXX)"
+
+ "$(qt5_get_bindir)/"lrelease ${PN}.pro || die
+
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}