summaryrefslogtreecommitdiff
path: root/sys-boot/woeusb-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-28 02:00:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-28 02:00:16 +0000
commita2148b9fab4c83209816a49f091d70873b19881d (patch)
treeaeeaea24918f3a0df7fc0e4e013c68df40469897 /sys-boot/woeusb-ng
parentead7697a01fd631b56240b2d58aedd98ba7f92d3 (diff)
gentoo auto-resync : 28:11:2024 - 02:00:16
Diffstat (limited to 'sys-boot/woeusb-ng')
-rw-r--r--sys-boot/woeusb-ng/Manifest5
-rw-r--r--sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-fix-pkg-discovery.patch28
-rw-r--r--sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-skip-postinstall.patch13
-rw-r--r--sys-boot/woeusb-ng/metadata.xml15
-rw-r--r--sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild69
5 files changed, 130 insertions, 0 deletions
diff --git a/sys-boot/woeusb-ng/Manifest b/sys-boot/woeusb-ng/Manifest
new file mode 100644
index 000000000000..474acb565eb1
--- /dev/null
+++ b/sys-boot/woeusb-ng/Manifest
@@ -0,0 +1,5 @@
+AUX woeusb-ng-0.2.12-fix-pkg-discovery.patch 880 BLAKE2B 6c23d4cd67c31c2526a0ee8aa27d4e9e3ff8340e1ef6155fe17452fb85ab27522579f1fd358df0e12d1571b6e04c5da373ca4364519a20c813692b8aa0896ca8 SHA512 64cefdd90efd79ec673338d031f05469f42b80e62f25bcdd5c6afba97775cadc800a7ad4a5750105bd9473effe23beca425110d8d2da5f49985677c7bee540d5
+AUX woeusb-ng-0.2.12-skip-postinstall.patch 315 BLAKE2B 47d2cc6fff0c2efefedb2c56b74ae16dfe644beb63057c601a173e4562164a93e469fd7e6934a884a104d650d19ac06e781ef8f77954f173711bf8c5a0619dcf SHA512 897aa005c694f4a029df20819a260d3047def0f67a7cc2110b1943066ab7905ce93565dfea3db6d4ce66399b549b162c3fcec7f288bf4c8d96e983dbfaae5e14
+DIST woeusb-ng-0.2.12.tar.gz 219102 BLAKE2B d146697ce4143adc62b489a5dbd09bd2dd02d910a51357a27b1a92663eee279c6fa3bdd39b0f01e46f445cb0170c3b0dbf37ed7fdc442386247ff2acb85791e8 SHA512 3323d1f33f3c009652555ca20827d3ab902a59c21b4e57725ac7efb702c60c8ab8a572f77c7f5e4da91713ea5412811358870d6100e13e5828421645b7464c38
+EBUILD woeusb-ng-0.2.12.ebuild 1618 BLAKE2B b8c295f977076622918d902bea8b4c47f172d5d95c6d93d167c3d05715f46cb2eee285c674c86c31308cb0d3ce81f04e9173160f24d94306da78db10057c5ac1 SHA512 5961ffdf6f7620bcf6e4761d3844ceef016f83bd7010818fb26d57d9aed41d450804ec2706972f8c1f1ef3e1b0e64211d19aaa1b7774fc799ce4e751d7cc5d56
+MISC metadata.xml 497 BLAKE2B 40fd7bb5fc765a4816c475822f9ecdb18015adf19457ec5a3793f049a3b3127d787d02fc5a2ad33a5921b539d687ce5b78bfe32a3465b60d28eeb78ebc541859 SHA512 5ee245b32a1ac18630a5655b88d204e0239bda0badb7a648acda4b5cc65e9233510c25edd85184675527a5265e3aec6260b76c5012378d74e5741eaad34cd487
diff --git a/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-fix-pkg-discovery.patch b/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-fix-pkg-discovery.patch
new file mode 100644
index 000000000000..33d84aa3179b
--- /dev/null
+++ b/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-fix-pkg-discovery.patch
@@ -0,0 +1,28 @@
+Fix setuptools package discovery issues by using custom discovery.
+
+```
+/usr/lib/python3.12/site-packages/setuptools/command/build_py.py:212: _Warning: Package 'WoeUSB.data' is absent from the `packages` configuration.
+ ```
+
+There's an open PR to improve the packaging methods.
+https://github.com/WoeUSB/WoeUSB-ng/pull/79
+--- a/setup.py
++++ b/setup.py
+@@ -2,7 +2,7 @@ import os
+ import shutil
+ import stat
+
+-from setuptools import setup
++from setuptools import setup, find_namespace_packages
+ from setuptools.command.develop import develop
+ from setuptools.command.install import install
+
+@@ -57,7 +57,7 @@ setup(
+ author_email='jakubmateusz@poczta.onet.pl',
+ license='GPL-3',
+ zip_safe=False,
+- packages=['WoeUSB'],
++ packages=find_namespace_packages(exclude=['doc', 'miscellaneous']),
+ include_package_data=True,
+ scripts=[
+ 'WoeUSB/woeusb',
diff --git a/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-skip-postinstall.patch b/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-skip-postinstall.patch
new file mode 100644
index 000000000000..3f632d3db67c
--- /dev/null
+++ b/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-skip-postinstall.patch
@@ -0,0 +1,13 @@
+Prevent installing files to hardcoded locations.
+
+There's an open PR to improve the packaging methods.
+https://github.com/WoeUSB/WoeUSB-ng/pull/79
+--- a/setup.py
++++ b/setup.py
+@@ -68,6 +68,5 @@ setup(
+ ],
+ cmdclass={
+ 'develop': PostDevelopCommand,
+- 'install': PostInstallCommand
+ }
+ )
diff --git a/sys-boot/woeusb-ng/metadata.xml b/sys-boot/woeusb-ng/metadata.xml
new file mode 100644
index 000000000000..bbe0695f9f03
--- /dev/null
+++ b/sys-boot/woeusb-ng/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>pastalian46@gmail.com</email>
+ <name>Takuya Wakazono</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">WoeUSB/WoeUSB-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild b/sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild
new file mode 100644
index 000000000000..6b4066c6c6a9
--- /dev/null
+++ b/sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit desktop distutils-r1 optfeature xdg
+
+MY_PN="WoeUSB-ng"
+DESCRIPTION="Create a Windows USB stick installer from an iso image (rewrite of WoeUSB)"
+HOMEPAGE="https://github.com/WoeUSB/WoeUSB-ng"
+SRC_URI="https://github.com/WoeUSB/WoeUSB-ng/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gui"
+
+RDEPEND="
+ !sys-boot/woeusb
+ app-arch/p7zip
+ sys-apps/util-linux
+ sys-block/parted
+ sys-boot/grub:2
+ sys-fs/dosfstools
+ sys-fs/ntfs3g[ntfsprogs]
+ $(python_gen_cond_dep '
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ gui? ( dev-python/wxpython:4.0[${PYTHON_USEDEP}] )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-pkg-discovery.patch
+ "${FILESDIR}"/${P}-skip-postinstall.patch
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+ python_fix_shebang WoeUSB
+
+ # fix hardcoded org.freedesktop.policykit.exec.path
+ sed -i "s|/usr/local/bin|${EPREFIX}/usr/bin|" \
+ miscellaneous/com.github.woeusb.woeusb-ng.policy \
+ WoeUSB/utils.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use gui; then
+ dobin WoeUSB/woeusbgui
+
+ insinto /usr/share/polkit-1/actions
+ doins miscellaneous/com.github.woeusb.woeusb-ng.policy
+
+ doicon -s 256 WoeUSB/data/woeusb-logo.png
+ make_desktop_entry woeusbgui WoeUSB-ng woeusb-logo Utility
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "Legacy PC bootmode support" "sys-boot/grub:2[grub_platforms_pc]"
+}