summaryrefslogtreecommitdiff
path: root/sys-boot/woeusb/woeusb-5.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sys-boot/woeusb/woeusb-5.2.4.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sys-boot/woeusb/woeusb-5.2.4.ebuild')
-rw-r--r--sys-boot/woeusb/woeusb-5.2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-boot/woeusb/woeusb-5.2.4.ebuild b/sys-boot/woeusb/woeusb-5.2.4.ebuild
new file mode 100644
index 000000000000..4f1d25c96d02
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-5.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/WoeUSB/WoeUSB"
+SRC_URI="https://github.com/WoeUSB/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/WoeUSB-${PV}"
+
+LICENSE="CC-BY-SA-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/wimlib
+ sys-apps/util-linux
+ sys-block/parted
+ sys-boot/grub:2[grub_platforms_pc]
+ sys-fs/dosfstools
+ sys-fs/ntfs3g"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i "s/@@WOEUSB_VERSION@@/${PV}/" sbin/${PN} share/man/man1/${PN}.1 || die
+}
+
+src_install() {
+ dosbin sbin/${PN}
+ doman share/man/man1/${PN}.1
+
+ einstalldocs
+}