summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
commit2e512e4e32285f8c4eb19586d014cb9d31454ec9 (patch)
treee5884cadbd260c6936495a63b92f4503d54e5428 /sys-boot
parent5264c18a325553759d67fb4e059db03cf3fc5c81 (diff)
gentoo auto-resync : 19:02:2025 - 00:15:15
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5906 -> 5904 bytes
-rw-r--r--sys-boot/gnu-efi/Manifest2
-rw-r--r--sys-boot/gnu-efi/gnu-efi-4.0.0.ebuild22
3 files changed, 15 insertions, 9 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index 113b053b1fad..f4a382555588 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/gnu-efi/Manifest b/sys-boot/gnu-efi/Manifest
index d34efa157256..16c3c7277f8d 100644
--- a/sys-boot/gnu-efi/Manifest
+++ b/sys-boot/gnu-efi/Manifest
@@ -11,5 +11,5 @@ EBUILD gnu-efi-3.0.15.ebuild 1917 BLAKE2B cd98c39082b4d0e8bdf2181738b81a115842eb
EBUILD gnu-efi-3.0.17.ebuild 1948 BLAKE2B 6e9c1ea853cd12b47e60c25e889306698dbfba6cffb10fd7f7bac0ef3410d882559659d3f6f23f953d8c9071930a41875b0c75ca17b871bd3c852af891457dc3 SHA512 b5b46e15baca02080f3236ab796c8dfbed0c2cdf31593e9810304a9a853091492e47adb9429a7a82da6b50de5c6917f8a61a4588e78190d70af970d8126eb58e
EBUILD gnu-efi-3.0.18-r5.ebuild 3870 BLAKE2B 310a7d020e19383faada9e5c5fd8475330b90e747e88d4bc1b6e73e0f91f26faf99376e901ce9706f75d5c011286e803135bd98f5490aac79960f208200536bc SHA512 b0ec2b61f890c93e38e7ad0846497b83dc99448ab6dbb4c39e286cfced1181184b220cd91e130f521e073ad0db883e4d3ecfdae3e18c7120022f9f0d524abe89
EBUILD gnu-efi-3.0.19.ebuild 3898 BLAKE2B 3302e1e0553478936cd6f82c943d9a9f25a11bb87363d04d05858d293985e915b81c3d1e1e59576b28862f222ac743cba1c8eec90aa66b40679423ca65233dd5 SHA512 a736278f3039de4b6059c886421c710885679bf5e6dbb2dbbf046f494446a4831ffb2914db611d43c8d09d29ddc09aba0f5724866045d34fa807e0744a289066
-EBUILD gnu-efi-4.0.0.ebuild 3890 BLAKE2B 79d2e8ea2e7e6b4514bb20559ce3b602065bc116bd5173dcb1332ed81df443437503bfbc2ae1ea14df6e1780a161de7a9255c254c13588e8d545aa8e9940685d SHA512 5b12124d321326910a9e2e32eb9447f3aa379bbc91df92cf515979393357caeab2e734f76bf47274b5c0e70a7abcc3eeed24d2a7035eda381eaeed02809aa27b
+EBUILD gnu-efi-4.0.0.ebuild 3985 BLAKE2B ba2e972bbd65c31f47a71921814e2437b95962e546715fe88628199855dd7716ca2cffaec020185891a8d473613f0aecbd3976668a54346fed62483a781ecd2d SHA512 0e6c8e4fb0aba21ac8f2107b3eeb1da510fe4f25f7cb3dd5a476c9551ec71a2cb81213d1a350bb36fb92d10f3b37aa8829a63c9af3fb597adb6a77e827668078
MISC metadata.xml 381 BLAKE2B a3cbadc2ae97d29ac87c04f3209cd7f4879ef70903907f319b425f038f07fd6bbc357a0291e70909a3b0b2097de6b63daf0f568d0fd7097c7bd2d9c9c7f3a963 SHA512 abbdda69a47f94442977af7491596e40873767256f5e75c3c06b614a369ec8cb7103a132e77a95c99ba24e4b205e5c3fc267039c920c1268a19b17e4ac779b79
diff --git a/sys-boot/gnu-efi/gnu-efi-4.0.0.ebuild b/sys-boot/gnu-efi/gnu-efi-4.0.0.ebuild
index e491f3efcf05..746849679dbb 100644
--- a/sys-boot/gnu-efi/gnu-efi-4.0.0.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-4.0.0.ebuild
@@ -39,26 +39,32 @@ DOCS="README* SECURITY* docs/*"
check_and_set_objcopy() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
+
+ if use arm || use riscv; then
+ # bug #939338
+ # objcopy does not understand PE/COFF on these arches: arm32, riscv64 and mips64le
+ # gnu-efi containes a workaround
+ return 0
+ fi
+
# bug #931792
# llvm-objcopy does not support EFI target, try to use binutils objcopy or fail
tc-export OBJCOPY
- OBJCOPY="${OBJCOPY/llvm-/}"
# Test OBJCOPY to see if it supports EFI targets, and return if it does
LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' && return 0
+
# If OBJCOPY does not support EFI targets, it is possible that the 'objcopy' on our path is
# still LLVM if the 'binutils-plugin' USE flag is set. In this case, we check to see if the
# '(prefix)/usr/bin/objcopy' binary is available (it should be, it's a dependency), and if
# so, we use the absolute path explicitly.
- local binutils_objcopy="${EPREFIX}"/usr/bin/"${OBJCOPY}"
+ local binutils_objcopy="${EPREFIX}"/usr/bin/objcopy
if [[ -e "${binutils_objcopy}" ]]; then
OBJCOPY="${binutils_objcopy}"
+ einfo "Forcing OBJCOPY=${OBJCOPY}"
fi
- if ! use arm && ! use riscv; then
- # bug #939338
- # objcopy does not understand PE/COFF on these arches: arm32, riscv64 and mips64le
- # gnu-efi containes a workaround
- LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
- fi
+
+ # Test OBJCOPY again to see if it supports EFI targets, and fail if it doesn't
+ LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
fi
}