summaryrefslogtreecommitdiff
path: root/sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 10:26:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 10:26:32 +0100
commit398c033d3c836f59a4f2668f3c27b680b7ed1f54 (patch)
tree20e04ac898fb62cfe0a84af35b5382855496b334 /sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild
parentf5d9305cc82b2e211fdaba92618c07829ffb2c48 (diff)
gentoo auto-resync : 06:09:2022 - 10:26:32
Diffstat (limited to 'sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild')
-rw-r--r--sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild b/sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild
new file mode 100644
index 000000000000..e43e5f859ec7
--- /dev/null
+++ b/sys-cluster/k9scli/k9scli-0.25.18-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=6085039f
+
+DESCRIPTION="terminal based UI to manage kubernetes clusters"
+HOMEPAGE="https://k9scli.io"
+SRC_URI="https://github.com/derailed/k9s/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/k9s-${PV}"
+
+src_prepare() {
+ default
+ # I will look into opening an upstream PR to do this.
+ sed -i -e 's/-w -s -X/-X/' Makefile || die
+}
+
+src_compile() {
+ emake GIT=${GIT_COMMIT} VERSION=v${PV} build
+}
+
+src_install() {
+ dobin execs/k9s
+ dodoc -r change_logs plugins skins README.md
+}