summaryrefslogtreecommitdiff
path: root/sys-cluster/k9scli/k9scli-0.31.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 23:40:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 23:40:45 +0000
commite53a98716127eb7be20f46713a7442d5b8820633 (patch)
tree65a649f66422bc6677cae851cf42a166e45d2ced /sys-cluster/k9scli/k9scli-0.31.9.ebuild
parentfab95e98818bada1626a7723a1348f4e920d25e0 (diff)
gentoo auto-resync : 26:02:2024 - 23:40:45
Diffstat (limited to 'sys-cluster/k9scli/k9scli-0.31.9.ebuild')
-rw-r--r--sys-cluster/k9scli/k9scli-0.31.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/k9scli/k9scli-0.31.9.ebuild b/sys-cluster/k9scli/k9scli-0.31.9.ebuild
new file mode 100644
index 000000000000..6d7e38d5e05f
--- /dev/null
+++ b/sys-cluster/k9scli/k9scli-0.31.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+# update this on every bump
+GIT_COMMIT=f2f4077b
+
+DESCRIPTION="terminal based UI to manage kubernetes clusters"
+HOMEPAGE="https://k9scli.io"
+SRC_URI="https://github.com/derailed/k9s/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+S="${WORKDIR}/k9s-${PV}"
+
+src_prepare() {
+ default
+ # I will look into opening an upstream PR to do this.
+ sed -i -e 's/-w -s -X/-X/' Makefile || die
+}
+
+src_compile() {
+ emake GIT_REV=${GIT_COMMIT} VERSION=v${PV} build
+}
+
+src_install() {
+ dobin execs/k9s
+ dodoc -r change_logs plugins skins README.md
+}