summaryrefslogtreecommitdiff
path: root/sys-cluster/kubeseal/kubeseal-0.20.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /sys-cluster/kubeseal/kubeseal-0.20.2.ebuild
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'sys-cluster/kubeseal/kubeseal-0.20.2.ebuild')
-rw-r--r--sys-cluster/kubeseal/kubeseal-0.20.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/kubeseal/kubeseal-0.20.2.ebuild b/sys-cluster/kubeseal/kubeseal-0.20.2.ebuild
new file mode 100644
index 000000000000..d4f364c86e91
--- /dev/null
+++ b/sys-cluster/kubeseal/kubeseal-0.20.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+MY_PN="sealed-secrets"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Client-side utility for one-way encrypted secrets in kubernetes"
+HOMEPAGE="https://github.com/bitnami-labs/sealed-secrets"
+SRC_URI="https://github.com/bitnami-labs/sealed-secrets/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${MY_P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+BDEPEND=">=dev-lang/go-1.19"
+
+RESTRICT+=" test"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" VERSION="v${PV}" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+}