summaryrefslogtreecommitdiff
path: root/sys-cluster/legion/legion-17.08.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sys-cluster/legion/legion-17.08.0-r1.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sys-cluster/legion/legion-17.08.0-r1.ebuild')
-rw-r--r--sys-cluster/legion/legion-17.08.0-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/sys-cluster/legion/legion-17.08.0-r1.ebuild b/sys-cluster/legion/legion-17.08.0-r1.ebuild
deleted file mode 100644
index c883f98f82d2..000000000000
--- a/sys-cluster/legion/legion-17.08.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A data-centric parallel programming system"
-HOMEPAGE="https://legion.stanford.edu/"
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
-else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="gasnet +hwloc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc:= )
- "
-RDEPEND="${DEPEND}"
-
-src_configure() {
- mycmakeargs=(
- -DLegion_USE_HWLOC=$(usex hwloc)
- -DLegion_USE_GASNet=$(usex gasnet)
- -DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
- -DLegion_BUILD_EXAMPLES=ON
- -DLegion_BUILD_TESTS=ON
- -DLegion_BUILD_TUTORIAL=ON
- )
- cmake-utils_src_configure
-}