summaryrefslogtreecommitdiff
path: root/sys-cluster/pbs-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/pbs-python
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/pbs-python')
-rw-r--r--sys-cluster/pbs-python/Manifest5
-rw-r--r--sys-cluster/pbs-python/metadata.xml8
-rw-r--r--sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild41
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-cluster/pbs-python/Manifest b/sys-cluster/pbs-python/Manifest
new file mode 100644
index 000000000000..8ba9162031bc
--- /dev/null
+++ b/sys-cluster/pbs-python/Manifest
@@ -0,0 +1,5 @@
+DIST pbs_python-4.3.3.tar.gz 185442 SHA256 d149803973f8db52ca62a49e69e9e34b4d8726d8b7fa480f909d345dca9dd2b8 SHA512 2a8c49d0be887cd7c5f9c17bd7ce679c7c04481c70e6949fd430007b7678c15636e8416fd30ac16d06cc387680bd4f9d3df8cad8be7b512b6fa2785891338044 WHIRLPOOL 15db1b5bae67b3eca4924a596d7040305f13b37c030314c268734b3d5c1145aa8f99196dd405ee802062daa41fd24cacc02f60ccd738c84e83601ef2309aef02
+EBUILD pbs-python-4.3.3-r1.ebuild 760 SHA256 4ffc108b728de4bd736221a912ee4696c55e65b6e13d351aa86102bd5ee7f270 SHA512 aa8a60da40ca583713285734313804c350d106500e58ebb966c203936eb297e054d77daaf5a133d6cc72f59f2378ddfd59760ef9bd52e67ecf76ebb8f0b1b0ae WHIRLPOOL 3326c5370f828d94f5357c331cbd456a361380fe972f07099f58d44bd498f92cf9e4807788c56810caeffed9d624195a1e30a06fc9caf6b1814e19e74e8a177f
+MISC ChangeLog 2445 SHA256 50c3bcaf3008330ba425e4ad4ffee0fca529be9e45a8360f66ad32c6b887516b SHA512 548bdbc0ef3229f856d590c7e73d336b42b2aaf573955ccec9a3599a8fc978edfb0134fd21a4f175d8380306aff8436f8371d64bf90b9f1b39b2459d905a1087 WHIRLPOOL 5836387ef43e714d804914983f8af9fb3568df8559a5c34c4efa836cf037e837b073e4e1ced98322bc0668c660ee694f4bd98fd1deca07d2ae4681a82db3d762
+MISC ChangeLog-2015 1540 SHA256 eae3322c88659bc2b5fc26310ca6b43a37c3d0fbc0a2c2bd7092be94bc1a6564 SHA512 a3a844664d842bff5de9a927f58f935ebaa90d960268b2862be994c2cd882dbadfd0ac08cc40a6833206180c5a86a80c27021f0f8391773d473758c615fa159a WHIRLPOOL ae21a0c6e0c4859667b334a9e04063129c6823b468898d1ecd8f21734da81badfdf7f1eb92736c015e6c1d093b7f820d19a2f01a0b4591705ed4d94c3bafd388
+MISC metadata.xml 257 SHA256 eba5a727fcb9e27d2a6e5dac0c92b252de676d434ef19bb09d44534257bed08c SHA512 d01f4b592393076365e924fcc717c807172488f03a7b64542238616207fd00dacd096c383e68b9558142f7dab357578f91904f73acd41ce3a6ba7b7ef72b4980 WHIRLPOOL 8621cedc31dcd2b89dffd18c102b491aea21946189d752b9dfc3b686aea7adfff6782a3c7796d777e18677b7dd99f1cd8584022642eaf009cab3b733918a501b
diff --git a/sys-cluster/pbs-python/metadata.xml b/sys-cluster/pbs-python/metadata.xml
new file mode 100644
index 000000000000..8bf4b5f36954
--- /dev/null
+++ b/sys-cluster/pbs-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild b/sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild
new file mode 100644
index 000000000000..d7f9338f422a
--- /dev/null
+++ b/sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+
+DESCRIPTION="Python bindings to the Torque C API"
+HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
+
+LICENSE="openpbs"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="sys-cluster/torque"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -i -e "s/4.1.3/${PV}/" setup.py.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ econf
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins "${S}"/examples/*
+ fi
+}