summaryrefslogtreecommitdiff
path: root/sys-cluster/prrte
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-24 14:56:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-24 14:56:08 +0100
commitc9b5a916efac64df2a39870a92cc6b67116d1b9f (patch)
tree126347f55a7e5eeddecc17d5a26886ffb11249f4 /sys-cluster/prrte
parentb818f6a820dceae80d6e3faac5fdf7be0c6fcbe2 (diff)
gentoo auto-resync : 24:08:2024 - 14:56:07
Diffstat (limited to 'sys-cluster/prrte')
-rw-r--r--sys-cluster/prrte/Manifest3
-rw-r--r--sys-cluster/prrte/metadata.xml11
-rw-r--r--sys-cluster/prrte/prrte-3.0.6.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-cluster/prrte/Manifest b/sys-cluster/prrte/Manifest
new file mode 100644
index 000000000000..c55234748308
--- /dev/null
+++ b/sys-cluster/prrte/Manifest
@@ -0,0 +1,3 @@
+DIST prrte-3.0.6.tar.gz 5976755 BLAKE2B 62cff51ebb7e72c32a237eb36db925f5bf5811cf5f409619128fa8ef490d3ba9e6ba4a1701edd21486878974088ff17645c98dab12904abd48c4a4b50453f807 SHA512 f7d3a1bedc0029fcb0e4e906a099d1de07b171805f0cc8d6e443826b8c321e3d5e7fa80867d8ab9ae1f628446a1a8f663231d8b67e243650582225805adc6e9d
+EBUILD prrte-3.0.6.ebuild 879 BLAKE2B 374826cd5e7471e87a8287210f7ae8fb1c4c0cbff98b9473d0d5cde3dc63fa9a1859dd97e98f5bc6971b1d6cf1d0111817aba83f372f80331fde169069d016e6 SHA512 e229bfbdeff6aae7a9fc428e89201492d4206127a8c0e24e91c452cdd0608def3178e4a1729a521fb02098040ce640babd5e7841a227cb9b20388885051445e4
+MISC metadata.xml 337 BLAKE2B 91c8edbbf432d72f02c4e8901c2ae9148f727b024098d3497bfb3c631c359b6d790c177ffc600248bbd3955ebfe8e7ff74c0c4960507574d52edc10b2a9935eb SHA512 cafdf860ef4a40f97eafca4431a3418247b3d424307c4c2ed1c573c024a89def4072b375faa08311f9f62c836bfd29a16f46a327d5cc7b563a677fe62acb605f
diff --git a/sys-cluster/prrte/metadata.xml b/sys-cluster/prrte/metadata.xml
new file mode 100644
index 000000000000..51ef0c126080
--- /dev/null
+++ b/sys-cluster/prrte/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openpmix/prrte</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-cluster/prrte/prrte-3.0.6.ebuild b/sys-cluster/prrte/prrte-3.0.6.ebuild
new file mode 100644
index 000000000000..6790ea5231fa
--- /dev/null
+++ b/sys-cluster/prrte/prrte-3.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="PMIx Reference RunTime Environment"
+HOMEPAGE="https://openpmix.github.io/"
+SRC_URI="https://github.com/openpmix/prrte/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+DEPEND="
+ dev-libs/libevent:=
+ sys-apps/hwloc:=
+ >=sys-cluster/pmix-4.2.4
+"
+RDEPEND="${DEPEND}"
+
+# There is no testsuite at least today.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ #
+ # Same issue as its companion project sys-cluster/pmix, and logically
+ # solvable in tandem (or never).
+ # https://github.com/openpmix/openpmix/issues/3350
+ filter-lto
+
+ econf
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}