summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/singularity/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/singularity/files')
-rw-r--r--sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch28
-rw-r--r--sys-cluster/singularity/files/singularity-2.3.1-slurm.patch54
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch b/sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch
new file mode 100644
index 000000000000..e550811dc676
--- /dev/null
+++ b/sys-cluster/singularity/files/singularity-2.2.1-glibc-2.25.patch
@@ -0,0 +1,28 @@
+ src/lib/loop-control.c | 1 +
+ src/lib/mount/dev/dev.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/lib/loop-control.c b/src/lib/loop-control.c
+index f9ab2d6f..4bfed843 100644
+--- a/src/lib/loop-control.c
++++ b/src/lib/loop-control.c
+@@ -26,6 +26,7 @@
+ #include <sys/file.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <errno.h>
+ #include <string.h>
+ #include <fcntl.h>
+diff --git a/src/lib/mount/dev/dev.c b/src/lib/mount/dev/dev.c
+index 547157a4..c994c264 100644
+--- a/src/lib/mount/dev/dev.c
++++ b/src/lib/mount/dev/dev.c
+@@ -25,6 +25,7 @@
+ #include <sys/mount.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+
diff --git a/sys-cluster/singularity/files/singularity-2.3.1-slurm.patch b/sys-cluster/singularity/files/singularity-2.3.1-slurm.patch
new file mode 100644
index 000000000000..71a8d9972b75
--- /dev/null
+++ b/sys-cluster/singularity/files/singularity-2.3.1-slurm.patch
@@ -0,0 +1,54 @@
+From e858cfaf73eadb4cf4076a754c4836816c908d44 Mon Sep 17 00:00:00 2001
+From: Petr Votava <votava.petr@gene.com>
+Date: Thu, 29 Jun 2017 16:53:48 +0000
+Subject: [PATCH] A patch for slurm plugin build
+
+---
+ src/slurm/Makefile.am | 2 +-
+ src/slurm/singularity.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/slurm/Makefile.am b/src/slurm/Makefile.am
+index 860c7667d..152e41450 100644
+--- a/src/slurm/Makefile.am
++++ b/src/slurm/Makefile.am
+@@ -4,7 +4,7 @@ plugindir = $(libdir)/slurm
+ if WITH_SLURM
+ plugin_LTLIBRARIES = singularity_spank.la
+ singularity_spank_la_SOURCES = singularity.c
+-singularity_spank_la_LIBADD = ../lib/libsingularity_internal.la
++singularity_spank_la_LIBADD = ../lib/runtime/libinternal.la
+ singularity_spank_la_LDFLAGS = -module -no-undefined -avoid-version -export-symbols-regex '^slurm_spank_|^plugin_'
+ endif
+
+diff --git a/src/slurm/singularity.c b/src/slurm/singularity.c
+index acddddfd1..3509f4d8e 100644
+--- a/src/slurm/singularity.c
++++ b/src/slurm/singularity.c
+@@ -22,6 +22,7 @@
+
+ #define _GNU_SOURCE 1
+
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+@@ -29,9 +30,9 @@
+ #include <string.h>
+
+ #include "config.h"
+-#include "lib/singularity.h"
+ #include "util/util.h"
+ #include "util/file.h"
++#include "util/registry.h"
+
+ #include "slurm/spank.h"
+
+@@ -169,7 +170,6 @@ static int setup_container(spank_t spank)
+ }
+
+
+- char *image;
+ if ( ( image = singularity_registry_get("IMAGE") ) == NULL ) {
+ singularity_message(ERROR, "SINGULARITY_CONTAINER not defined!\n");
+ }