summaryrefslogtreecommitdiff
path: root/sys-cluster/ucx/ucx-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /sys-cluster/ucx/ucx-1.3.0.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'sys-cluster/ucx/ucx-1.3.0.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.3.0.ebuild b/sys-cluster/ucx/ucx-1.3.0.ebuild
new file mode 100644
index 000000000000..eb6c279f6453
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ numa? ( sys-process/numactl )
+"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}