summaryrefslogtreecommitdiff
path: root/sys-cluster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
commitad108e7b751d67723534624b94eb0e04250dd1af (patch)
treeb2c2e47b9c23ac5a70d7170b3ba364b32da31944 /sys-cluster
parentc44ae5c03130467400468d0e9a7f83e723c99f35 (diff)
gentoo auto-resync : 29:03:2025 - 00:32:15
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/Manifest.gzbin11553 -> 11554 bytes
-rw-r--r--sys-cluster/sanlock/Manifest1
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.5-r1.ebuild83
3 files changed, 84 insertions, 0 deletions
diff --git a/sys-cluster/Manifest.gz b/sys-cluster/Manifest.gz
index b5cfc0fed036..ea3cc55cc1d2 100644
--- a/sys-cluster/Manifest.gz
+++ b/sys-cluster/Manifest.gz
Binary files differ
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index 89f840196d47..223048e48442 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -5,5 +5,6 @@ AUX wdmd.initd 261 BLAKE2B 65b393f2f084896d3c17aa0345f9930badeec7a3ee4cc7e47bd0a
DIST sanlock-3.8.4.tar.gz 270031 BLAKE2B da011a15d488849d47fe1043df040580652558918dff9549bf4e6cb4077c03b4aaa8f8de5399dbb0e3f2301ae90c0d20599b25bd5e72bae5317b13f79a352333 SHA512 9fca2b18fd3bd504d5186de0b2626ea2c993997528de2384dc042afe52b2b68422a2e4bb79e2409c9e6eccbe5ea8d8939549eb25c5d16aa7fecf6c9a5798340c
DIST sanlock-3.8.5.tar.gz 270911 BLAKE2B 7f8146d67c620d22ded5205c1c621f3bbb36256a4c80e866575d8f324ad0237cf8bc07579f3aeda393dd0db85e27fdaa1aab1b6d7b931d4416d13f82d560e22a SHA512 8131e0b37ac47052a29d4b3a3e4286b06b862f08e827d3307f179eadbe97e4bc3e10f5c93f35042c308435ee81546a813227bce665a9735cbbf2b5a4a1f4474a
EBUILD sanlock-3.8.4-r1.ebuild 1866 BLAKE2B 0a39d3e12287fc5fa0858ce9c7c7f518290b8d5962aad1ccc7d694c75302e3e7c542480cdd80b1aa635c075ad4c247a9da3257b4537cd5412d40824eee36a877 SHA512 9ffd5ba43d287f86ece8573936fd19a3976f8d09050a0b79de8269c631827bbcaee2c56e97fc30a33d6cba5d048b370a42875b04ab8c4859f64e220b678e52bd
+EBUILD sanlock-3.8.5-r1.ebuild 2004 BLAKE2B 6933bf6cceff31ad02aaa4d68cb52b69350ef7b95a7e0e471132ad4a374680a2b931984ad6e93c56b6e9dd44ca0c712400d2d7eed432ff29756fe2e55d2fcaed SHA512 75c945a0655c14e13d29262c2c3f328693211d8c4f10f61f0c3bf2b3b2a2f31037e0e5a3cdaa5d79c917e41ca2801f472cde585967468fde805e5ae404925af9
EBUILD sanlock-3.8.5.ebuild 1997 BLAKE2B f96215b0fa73721d18e9c18acec59952de516d19fcaacbe7e78f27967196bc44302563c27c7655db43cd45fa76ee1b4f1303dd75740a40b67c90e554fee85433 SHA512 5a3b4e38c9e6b92c1a02352cfa91600041531f81a8f6f727e87780daaa6e3504cbff0a4d21caf966e61d7d012eaac8b0fa5b824dd48cf054eed851556ea775da
MISC metadata.xml 369 BLAKE2B a32cbc5e109bab37912ecc7efe951fcec96fb133b2861d3c38290e5f3aabe87e444d38bdbb18b711ba5836c43c7ac7ebcde3b5f23ec10df8c413cbd445c05ddf SHA512 ac7cb5f13743775baecae83e2c6beb6988b4c374db96217136cd68124e947890de32c9d7afecbdafbac32b0ac450ec2580b923f0e9fb63ef944463e879cd8283
diff --git a/sys-cluster/sanlock/sanlock-3.8.5-r1.ebuild b/sys-cluster/sanlock/sanlock-3.8.5-r1.ebuild
new file mode 100644
index 000000000000..69b184570572
--- /dev/null
+++ b/sys-cluster/sanlock/sanlock-3.8.5-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit flag-o-matic linux-info python-r1 systemd
+
+DESCRIPTION="shared storage lock manager"
+HOMEPAGE="https://pagure.io/sanlock"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+ GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/libaio
+ sys-apps/util-linux
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ acct-user/${PN}
+ acct-group/${PN}
+ ${DEPEND}
+"
+BDEPEND="sys-apps/which"
+
+PATCHES=(
+ "${FILESDIR}/sanlock-fence_sanlock-LDFLAGS.patch"
+ "${FILESDIR}/sanlock-3.8.4-implicit-func-decls.patch"
+)
+
+CONFIG_CHECK="~SOFT_WATCHDOG"
+
+src_compile() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/863734
+ # https://pagure.io/sanlock/issue/10
+ filter-lto
+
+ for d in wdmd src fence_sanlock reset; do
+ emake -C ${d}
+ done
+
+ if use python; then
+ python_foreach_impl emake -C python
+ fi
+}
+
+src_install() {
+ for d in wdmd src fence_sanlock reset; do
+ emake -C ${d} DESTDIR="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ done
+
+ if use python; then
+ python_foreach_impl emake -C python DESTDIR="${D}" install
+ fi
+
+ # config
+ dodir /etc/wdmd.d
+ dodir /etc/sanlock
+ insinto /etc/sanlock
+ doins src/sanlock.conf
+
+ # init
+ newconfd init.d/sanlock.sysconfig sanlock
+ newconfd init.d/wdmd.sysconfig wdmd
+ newinitd "${FILESDIR}"/sanlock.initd sanlock
+ newinitd "${FILESDIR}"/wdmd.initd wdmd
+ #doinitd ${FILESDIR}/sanlk-resetd.initd
+ #doinitd ${FILESDIR}/fence_sanlockd.initd
+
+ # systemd
+ systemd_newunit init.d/sanlock.service.native sanlock.service
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native || die
+ systemd_newunit init.d/wdmd.service.native wdmd.service
+ systemd_dounit init.d/sanlk-resetd.service
+ #systemd_dounit ${FILESDIR}/fence_sanlockd.service
+}