summaryrefslogtreecommitdiff
path: root/sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-16 17:29:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-16 17:29:23 +0000
commitc1fba876b88db3fefeead96efa966559036e656b (patch)
tree15ca12538bdba6298b7393592b713e3c5c896bef /sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild
parentaafe376c08b0a844bae25813092c119b165798da (diff)
gentoo auto-resync : 16:01:2024 - 17:29:23
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild b/sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild
index d892d1c763d9..46b656a4b514 100644
--- a/sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-8.2.1-r103.ebuild
@@ -25,6 +25,16 @@ BDEPEND=""
S="${WORKDIR}/darwin-xtools-gentoo-${PVR}"
+src_prepare() {
+ cmake_src_prepare
+ # kill forced libstd=libc++ usage, breaks with GCC-13 which has
+ # preliminary support for that
+ # check_cxx_compiler_flag(-stdlib=libc++ # XTOOLS_CXX_HAS_STDLIB_FLAG)
+ #
+ sed -i -e '/check_cxx_compiler_flag/s/XTOOLS_CXX_HAS_STDLIB_FLAG/NO_&/' \
+ cmake/config-ix.cmake || die
+}
+
src_configure() {
CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then