summaryrefslogtreecommitdiff
path: root/sys-devel/binutils/binutils-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /sys-devel/binutils/binutils-9999.ebuild
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'sys-devel/binutils/binutils-9999.ebuild')
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index 5e72d97d1403..8b89c6e8abe6 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,10 @@ inherit eutils libtool flag-o-matic gnuconfig multilib versionator
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
LICENSE="GPL-3+"
-IUSE="+cxx doc multitarget +nls static-libs test"
+# USE="+cxx" is a transitional flag until llvm migrates to new flags:
+# bug #677888
+IUSE="+cxx default-gold doc +gold multitarget +nls +plugins static-libs test"
+REQUIRED_USE="cxx? ( gold plugins ) default-gold? ( gold )"
# Variables that can be set here:
# PATCH_VER - the patchset version
@@ -174,10 +177,15 @@ src_configure() {
cd "${MY_BUILDDIR}"
local myconf=()
+ if use plugins ; then
+ myconf+=( --enable-plugins )
+ fi
# enable gold (installed as ld.gold) and ld's plugin architecture
- if use cxx ; then
+ if use gold ; then
myconf+=( --enable-gold )
- myconf+=( --enable-plugins )
+ if use default-gold; then
+ myconf+=( --enable-gold=default )
+ fi
fi
if use nls ; then