summaryrefslogtreecommitdiff
path: root/sys-devel/bpf-toolchain
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-21 12:26:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-21 12:26:06 +0100
commitbad9bf87b08d293eb79ebe14d1882e77da2b0ced (patch)
tree2e95088a05ca299b8369979d4b47f0f846657be7 /sys-devel/bpf-toolchain
parentc431a44e3cfa102e5ef2c9d6bbac48e28c9b15cb (diff)
gentoo auto-resync : 21:08:2024 - 12:26:06
Diffstat (limited to 'sys-devel/bpf-toolchain')
-rw-r--r--sys-devel/bpf-toolchain/Manifest2
-rw-r--r--sys-devel/bpf-toolchain/bpf-toolchain-14.2.0_p1.ebuild232
2 files changed, 234 insertions, 0 deletions
diff --git a/sys-devel/bpf-toolchain/Manifest b/sys-devel/bpf-toolchain/Manifest
index 513ebed6020e..225dce824d46 100644
--- a/sys-devel/bpf-toolchain/Manifest
+++ b/sys-devel/bpf-toolchain/Manifest
@@ -1,4 +1,6 @@
+DIST binutils-2.43.1.tar.xz 28174300 BLAKE2B c4cd765cea326cd00b5cfe306e2937d820603b42f07a714ceb1349d36ddba0d45c3e125599dadf290d97954035c381781067155600ed87066e494cb9c4b34b45 SHA512 20977ad17729141a2c26d358628f44a0944b84dcfefdec2ba029c2d02f40dfc41cc91c0631044560d2bd6f9a51e1f15846b4b311befbe14f1239f14ff7d57824
DIST binutils-2.43.tar.xz 28175768 BLAKE2B 28b0a04a28273b76eab2d00e00160be889f155f77f5a9d8759ef8dce505c97e97641bf7ec70b92b731b520570a02b06e04e8215b068fcb1bb2573e9ef24732d9 SHA512 93e063163e54d6a6ee2bd48dc754270bf757a3635b49a702ed6b310e929e94063958512d191e66beaf44275f7ea60865dbde138b624626739679fcc306b133bb
DIST gcc-14.2.0.tar.xz 92306460 BLAKE2B 87baf2a06dfa75d8fb6cd62c747ef1f57d3b9bbbe33a360d9ed3de4b4dbeaa8d920504c67e409bd9863414202c14fd854b46108e984418171205119216d03d3b SHA512 932bdef0cda94bacedf452ab17f103c0cb511ff2cec55e9112fc0328cbf1d803b42595728ea7b200e0a057c03e85626f937012e49a7515bc5dd256b2bf4bc396
EBUILD bpf-toolchain-14.2.0-r2.ebuild 6452 BLAKE2B 2ce7aa3cbe5c72659934616ca9bdb1d2ee394deddeb9f730d416e27a7a6a319dd55c173e603913085f988df1eae6dbe335fec74fb895a94b57364b94cc72ee16 SHA512 72c5a45e713899b1a26d05afd9b47b69425b4e05252365f91faf3fea9663169aabe28609773e05da82cc71d711f4ba7fec23272ef57b9600f39ece9ca322ed2e
+EBUILD bpf-toolchain-14.2.0_p1.ebuild 6453 BLAKE2B ec76969f9ec5ea1fae06e1321204c76da4ca5967ea9035a78dd758b94b401533aefc5853a0abee317aea0544a193e9f6ba3a297443aed9207cad840a05d1e14f SHA512 a91ea44ba35cfc0fa82628e2f494084bdb1a28c41183c06f3ae559574abf881de22c34c8f9cd13807d8be1c5ca79e8ce1ea94c222f721b60c3430d01c7abfb51
MISC metadata.xml 599 BLAKE2B c41d219a2ba989105be860668dae9a75ed7283924017bc5f452853325f7800d90f87f3acd8c56c51efbc150a45d630f20dff2867a73753e4a71fef2cc5adea04 SHA512 c0e7d480106f9803602288191de6b5295d80c8f4da7458dd1630dcb40ea67cf0e1258865bd7be646306b60700c991ed15c487d54c083f2a65717ac46c27a70de
diff --git a/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0_p1.ebuild b/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0_p1.ebuild
new file mode 100644
index 000000000000..847ea82ad412
--- /dev/null
+++ b/sys-devel/bpf-toolchain/bpf-toolchain-14.2.0_p1.ebuild
@@ -0,0 +1,232 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo flag-o-matic toolchain-funcs
+
+# Versioning is just the GCC version in full (so may include a snapshot
+# date). Unlike dev-util/mingw64-toolchain, which this ebuild was heavily
+# inspired by, there's no "third component" here to version on, just
+# GCC + binutils.
+#
+# Do _p1++ rather than revbump on Binutils changes
+# Not using Gentoo patchsets for simplicity, their changes are mostly unneeded here.
+GCC_PV=${PV%_p*}
+BINUTILS_PV=2.43.1
+
+DESCRIPTION="All-in-one bpf toolchain for building DTrace and systemd without crossdev"
+HOMEPAGE="
+ https://gcc.gnu.org/
+ https://sourceware.org/binutils/
+ https://gcc.gnu.org/wiki/BPFBackEnd
+"
+SRC_URI="
+ mirror://gnu/binutils/binutils-${BINUTILS_PV}.tar.xz
+"
+if [[ ${GCC_PV} == *-* ]]; then
+ SRC_URI+=" mirror://gcc/snapshots/${GCC_PV}/gcc-${GCC_PV}.tar.xz"
+else
+ SRC_URI+="
+ mirror://gcc/gcc-${GCC_PV}/gcc-${GCC_PV}.tar.xz
+ mirror://gnu/gcc/gcc-${GCC_PV}/gcc-${GCC_PV}.tar.xz
+ "
+fi
+S="${WORKDIR}"
+
+# l1:binutils+gcc, l2:gcc(libraries)
+LICENSE="
+ GPL-3+
+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+bin-symlinks custom-cflags +strip"
+
+RDEPEND="
+ dev-libs/gmp:=
+ dev-libs/mpc:=
+ dev-libs/mpfr:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ bin-symlinks? (
+ !cross-bpf-unknown-none/binutils
+ !cross-bpf-unknown-none/gcc
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=()
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ tc-is-cross-compiler &&
+ die "cross-compilation of the toolchain itself is unsupported"
+}
+
+src_prepare() {
+ # rename directories to simplify both patching and the ebuild
+ mv binutils{-${BINUTILS_PV},} || die
+ mv gcc{-${GCC_PV},} || die
+
+ default
+}
+
+src_compile() {
+ # src_compile is kept similar to dev-util/mingw64-toolchain
+ # at least for now for ease of comparison etc.
+ #
+ # not great but do everything in src_compile given bootstrapping
+ # process needs to be done in steps of configure+compile+install
+ # (done modular to have most package-specific things in one place)
+
+ CTARGET=bpf-unknown-none
+
+ BPFT_D=${T}/root # moved to ${D} in src_install
+ local bpftdir=/usr/lib/${PN}
+ local prefix=${EPREFIX}${bpftdir}
+ local sysroot=${BPFT_D}${prefix}
+ local -x PATH=${sysroot}/bin:${PATH}
+
+ use custom-cflags || strip-flags # fancy flags are not realistic here
+
+ # global configure flags
+ local conf=(
+ --build=${CBUILD:-${CHOST}}
+ --target=${CTARGET}
+ --{doc,info,man}dir=/.skip # let the real binutils+gcc handle docs
+ MAKEINFO=: #922230
+ )
+
+ # binutils
+ local conf_binutils=(
+ --prefix="${prefix}"
+ --host=${CHOST}
+ --disable-cet
+ --disable-default-execstack
+ --disable-nls
+ --disable-shared
+ --with-system-zlib
+ --without-debuginfod
+ --without-msgpack
+ --without-zstd
+ )
+
+ # gcc (minimal -- if need more, disable only in stage1 / enable in stage3)
+ local conf_gcc=(
+ --prefix="${prefix}"
+ --host=${CHOST}
+ --disable-bootstrap
+ --disable-cc1
+ --disable-cet
+ --disable-gcov #843989
+ --disable-gomp
+ --disable-nls # filename collisions
+ --disable-libcc1
+ --disable-libquadmath
+ --disable-libsanitizer
+ --disable-libssp
+ --disable-libvtv
+ --disable-shared
+ --disable-werror
+ --enable-languages=c
+ --with-gcc-major-version-only
+ --with-system-zlib
+ --without-isl
+ --without-zstd
+ --disable-multilib
+ )
+
+ # libstdc++ may misdetect sys/sdt.h on systemtap-enabled system and fail
+ # (not passed in conf_gcc above given it is lost in sub-configure calls)
+ local -x glibcxx_cv_sys_sdt_h=no
+
+ # bpft-build <path/package-name>
+ # -> ./configure && make && make install && bpft-package()
+ # passes conf and conf_package to configure, and users can add options
+ # through environment with e.g.
+ # BPFT_BINUTILS_CONF="--some-option"
+ # EXTRA_ECONF="--global-option" (generic naming for if not reading this)
+ bpft-build() {
+ local id=${1##*/}
+ local build_dir=${WORKDIR}/${1}-build
+
+ # econf is not allowed in src_compile and its defaults are
+ # mostly unused here, so use configure directly
+ local conf=( "${WORKDIR}/${1}"/configure "${conf[@]}" )
+
+ local -n conf_id=conf_${id}
+ [[ ${conf_id@a} == *a* ]] && conf+=( "${conf_id[@]}" )
+
+ local -n extra_id=BPFT_${id^^}_CONF
+ conf+=( ${EXTRA_ECONF} ${extra_id} )
+
+ einfo "Building ${id} in ${build_dir} ..."
+
+ mkdir -p "${build_dir}" || die
+ pushd "${build_dir}" >/dev/null || die
+
+ edo "${conf[@]}"
+ emake MAKEINFO=: V=1
+ # -j1 to match bug #906155, other packages may be fragile too
+ emake -j1 MAKEINFO=: V=1 DESTDIR="${BPFT_D}" install
+
+ declare -f bpft-${id} >/dev/null && edo bpft-${id}
+
+ popd >/dev/null || die
+ }
+
+ # build with same ordering that crossdev would do
+ bpft-build binutils
+ bpft-build gcc
+
+ if use bin-symlinks; then
+ mkdir -p -- "${BPFT_D}${EPREFIX}"/usr/bin/ || die
+ local bin
+ for bin in "${sysroot}"/bin/*; do
+ ln -rs -- "${bin}" "${BPFT_D}${EPREFIX}"/usr/bin/ || die
+ done
+ fi
+
+ # Delete libdep.a, which has a colliding name and is useless for bpf,
+ # which does not make use of cross-library dependencies: the libdep.a
+ # for the native binutils will do.
+ rm -f ${sysroot}/lib/bfd-plugins/libdep.a || die
+
+ # portage doesn't know the right strip executable to use for CTARGET
+ # and it can lead to .a mangling, notably with 32bit (breaks toolchain)
+ dostrip -x ${bpftdir}/{${CTARGET}/lib{,32},lib/gcc/${CTARGET}}
+
+ # TODO: Check if this is worth doing, it may not be
+ if use strip; then
+ einfo "Stripping ${CTARGET} static libraries ..."
+ find "${sysroot}"/{,lib/gcc/}${CTARGET} -type f -name '*.a' \
+ -exec ${CTARGET}-strip --strip-unneeded {} + || die
+ fi
+}
+
+src_install() {
+ mv "${BPFT_D}${EPREFIX}"/* "${ED}" || die
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use bin-symlinks && has_version dev-util/shadowman && [[ ! ${ROOT} ]] &&
+ eselect compiler-shadow update all
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that this package is primarily intended for DTrace, systemd, and related"
+ elog "packages to depend on without needing a manual crossdev setup."
+ elog
+ elog "Settings are oriented only for what these need and simplicity."
+ elog "Use sys-devel/crossdev if need full toolchain/customization:"
+ elog " https://wiki.gentoo.org/wiki/Crossdev"
+ fi
+}
+
+pkg_postrm() {
+ use bin-symlinks && has_version dev-util/shadowman && [[ ! ${ROOT} ]] &&
+ eselect compiler-shadow clean all
+}