summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
commit2ad011cd42b40aebf90105be4521fb1727266d1d (patch)
treed9dc4f7c1665a6ba336ba8a9fa773f1292895b76 /sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild
parente0dcb1c4ea48292b379fadd53f55f1df42cf7eab (diff)
gentoo auto-resync : 26:09:2022 - 15:08:08
Diffstat (limited to 'sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild
new file mode 100644
index 000000000000..1285500128bb
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20220926.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}