summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /sys-devel/clang-common
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/Manifest1
-rw-r--r--sys-devel/clang-common/clang-common-8.0.9999.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/clang-common/Manifest b/sys-devel/clang-common/Manifest
index 9d974cf4058f..fda6c036b101 100644
--- a/sys-devel/clang-common/Manifest
+++ b/sys-devel/clang-common/Manifest
@@ -3,5 +3,6 @@ DIST cfe-7.0.1.src.tar.xz 12488668 BLAKE2B b80247b5caf81661dfa715d9bf454b8023221
EBUILD clang-common-6.0.1.ebuild 777 BLAKE2B 3f19ef0457ce59dffd312ee898a72b4b5e6d21a2f9403d159c2f92c76dd16f212beec6a906fc8652487a7bd7f0b773b86620ceb03ceeaa1974e9fd8bd021a830 SHA512 e469a91c0619ae0aca5f0c25bb14cb22fb5b773c452dbb212a32a499ff5101878455b28b2948fe118713ee5d9d15b24d470fde9a57ce38bbe46f26c0ed2c33da
EBUILD clang-common-7.0.1.ebuild 782 BLAKE2B 8afe6fcd75128ff16981bceccf9558b9e4a98135ecc2298bfceb0cb5c42aeb2e283f55077b6f13cb68d5986c7b77b0d48887c5bc2bfc4109b483be14378f4ce8 SHA512 ecf255096b76c75ab26de6b86db0633ab09a253fc9e4cf9bbe7adb8e5cf5eeab75309b5548ae6622761eb59743720058975ea48e62f553e097eae6f32bc8bc29
EBUILD clang-common-7.0.9999.ebuild 666 BLAKE2B f6c1fe58d00db323baffd3c426bb31d1835cf44b5554fbb8d7cbfd3a0ddfcfe968e0007465fdd13297c7aad3bf94b219c6d156e12fcfc95ea72e44a6f273dd40 SHA512 3ad6ab3333f0cbb4aea199b9409668f1ae5d3a1ba8e31f0a68e1dc1d2b4489cef0a54cf144c56ccb256feabe4bada8e764331ddf91c682eb4752527ce8bd54ad
+EBUILD clang-common-8.0.9999.ebuild 663 BLAKE2B 07c756fdc01c6a437104bd9c60d18e1aaed3605a2b2055d125077d001c61070b92aa663ffdf9e06ee0d7c2c02eafbaf584fe9733edce6dc19c6f0d434f9ca6bb SHA512 364a317e9cad676067a4b13990a4ba6a63270b10fb98a60c1bdbdb6ec94ba96db782b722d506e8735a9db9a8247a02632e11a70ad3b017af2ca515c1c08380cf
EBUILD clang-common-9999.ebuild 641 BLAKE2B 81f3432382ffcf77a61d9142a0ae83df84499da1ba31cbd542d2080bde11d92676efd0a9a19f1392f55a300fd9aaf7b0268a8dec7f017cd229eec4dde1b7091a SHA512 0e8661594be1482cda90f240792ae7a9e77c0ba167d874735f89994a24ebf232a5cb10858fc9099c9f639174f2fbf79b7eb16e05ca54d17c636002c72f68d7d5
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/sys-devel/clang-common/clang-common-8.0.9999.ebuild b/sys-devel/clang-common/clang-common-8.0.9999.ebuild
new file mode 100644
index 000000000000..c412694e6d73
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-8.0.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_80"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}