summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /sys-devel/clang-common
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/Manifest5
-rw-r--r--sys-devel/clang-common/clang-common-6.0.0.ebuild33
-rw-r--r--sys-devel/clang-common/clang-common-6.0.9999.ebuild33
-rw-r--r--sys-devel/clang-common/clang-common-9999.ebuild32
-rw-r--r--sys-devel/clang-common/metadata.xml7
5 files changed, 110 insertions, 0 deletions
diff --git a/sys-devel/clang-common/Manifest b/sys-devel/clang-common/Manifest
new file mode 100644
index 000000000000..2509027d315f
--- /dev/null
+++ b/sys-devel/clang-common/Manifest
@@ -0,0 +1,5 @@
+DIST cfe-6.0.0.src.tar.xz 11959224 BLAKE2B 257edbaedf72bd941b67b4aa2f152a96a37bbea72d21d22d4445152685efe40d75b9a7a39955545643e841ad6693ef12e52b207b9119098774f39e858b64bc09 SHA512 e886dd27448503bbfc7fd4f68eb089c19b2f2be4f0e5b26d3df253833f60b91d70b472a6b530063386e2252075b110ce9f5942800feddf6c34b94a75cf7bd5c6
+EBUILD clang-common-6.0.0.ebuild 773 BLAKE2B eb1d5d5c3a18c7b38535de505bddb911bce68f4c309140d4a0729af9e0db30e7c2ed5778504786a55af986c1be9ebbf5dec8bb3ac6bf0b9ed9a2bf1997997145 SHA512 cb3f0a5d923c3d67245b39a403527de37f58d9f97965309f345c336eb29abd7ef6581d45ad6c717499c03253b69c04d5f6ff9e8bcbe6fa1988411a31b038877d
+EBUILD clang-common-6.0.9999.ebuild 666 BLAKE2B dc0dec1a0c708ad38f971a0b33f7751c5c2936170f968b8c43ee1fab836d6f4e485ad898305e50ab6d711733248caac0a5d8769d18dac6838b1ffc315f7e7391 SHA512 4c81e883864a9408eefd53f91ef20bc74bcb87e4f14a1a4d644e7087f15239518b210c9471f800d2ebd326d6c3c5747a87436424c0a75757d85180b26bd2013f
+EBUILD clang-common-9999.ebuild 641 BLAKE2B 81f3432382ffcf77a61d9142a0ae83df84499da1ba31cbd542d2080bde11d92676efd0a9a19f1392f55a300fd9aaf7b0268a8dec7f017cd229eec4dde1b7091a SHA512 0e8661594be1482cda90f240792ae7a9e77c0ba167d874735f89994a24ebf232a5cb10858fc9099c9f639174f2fbf79b7eb16e05ca54d17c636002c72f68d7d5
+MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/sys-devel/clang-common/clang-common-6.0.0.ebuild b/sys-devel/clang-common/clang-common-6.0.0.ebuild
new file mode 100644
index 000000000000..05dbb18f31a4
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-6.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}
diff --git a/sys-devel/clang-common/clang-common-6.0.9999.ebuild b/sys-devel/clang-common/clang-common-6.0.9999.ebuild
new file mode 100644
index 000000000000..23946cca1614
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-6.0.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}
diff --git a/sys-devel/clang-common/clang-common-9999.ebuild b/sys-devel/clang-common/clang-common-9999.ebuild
new file mode 100644
index 000000000000..145e395e1fe0
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}
diff --git a/sys-devel/clang-common/metadata.xml b/sys-devel/clang-common/metadata.xml
new file mode 100644
index 000000000000..89c4bdb96049
--- /dev/null
+++ b/sys-devel/clang-common/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>llvm@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>