summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 17:22:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 17:22:12 +0100
commitb2a3508c3634488d32ec5bbe6b4365ab27185ebd (patch)
tree408b60b91a5427cc1ecb8a441c9df1f2526eeba1 /sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
parent8668c0f6c5fd1d084b8b2bdac1cfa1fcba412f65 (diff)
gentoo auto-resync : 19:09:2022 - 17:22:11
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild16
1 files changed, 1 insertions, 15 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
index c45769b02981..e4ff9326ddcb 100644
--- a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build toolchain-funcs
+inherit multilib-build
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -25,17 +25,3 @@ RDEPEND="
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-15,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}