summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 12:54:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 12:54:47 +0000
commitc98eb096c37a4252dc388920f0b0f8b2441c9b5d (patch)
treee1ea82832de33bd32a72125a46939916d1213cdd /sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild
parent6a69fdbc9519930f41e7eeb52543e60c1af5be49 (diff)
gentoo auto-resync : 16:11:2022 - 12:54:47
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.5.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"