summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-02 01:26:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-02 01:26:11 +0100
commitd39b2406e1496a2848b3f450a5737ae3dbd8c6f7 (patch)
tree2f21fa7a75d2873c67fb5d3faab2a0f60fb785ce /sys-devel/clang-runtime
parent95ce69d324747e9aa715e1761abab42204529b28 (diff)
gentoo auto-resync : 02:10:2024 - 01:26:10
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index c422e82c3c62..8a37f4c4b79d 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -3,6 +3,7 @@ EBUILD clang-runtime-16.0.6.ebuild 1448 BLAKE2B be376aab09a0268444784d1a0bcb5902
EBUILD clang-runtime-17.0.6.ebuild 1448 BLAKE2B be376aab09a0268444784d1a0bcb590222c9c8a118e260b15939e574687334eb476d6f66ab0f1f4fb0841a226c7b7f690666c33bec2d9c14f27a4f30f986b859 SHA512 b0b7a2f5c69890cb2fc0a9c2c8a1910669a4eae16826c0702a2ef508f91b6ec3b5607beab5b24f02951cf9b377f1d09395bd97c27f476137ef6cdf2571330578
EBUILD clang-runtime-18.1.8.ebuild 1454 BLAKE2B 73a5e4fd6e04978294419baf373c8e283107a1e6a4cfaf4995373cd73cfb97585eb651bd0f50d1c98cca2b77680e5249eb84ab9310c520b07a160ac5e43cc6d7 SHA512 00b3d8d185d739100002aef7f1c5e35fd70f3412573eafc6c9344b0ee272cd9c64cb721ec858907227841896b2a6ed0a7f21c31adca01205287f3427adb8c446
EBUILD clang-runtime-19.1.0.ebuild 1461 BLAKE2B 5f477947ea7a07f9f341baa7c0e0df31248fc6b5f949c84abfde5e69d9eb5ba8c2d9e8ee1de316279742c22817b743bdf9225c3ce3b0f4ac239080a1dd3b442a SHA512 7828ba3c785c06ccf3614bf51140899b990db826993457da7720d6884cf459f39545002ff7c5c8afb9f6fd6bbbe089890a10f483e679d831a0afef0559fd9fc3
+EBUILD clang-runtime-19.1.1.ebuild 1461 BLAKE2B 5f477947ea7a07f9f341baa7c0e0df31248fc6b5f949c84abfde5e69d9eb5ba8c2d9e8ee1de316279742c22817b743bdf9225c3ce3b0f4ac239080a1dd3b442a SHA512 7828ba3c785c06ccf3614bf51140899b990db826993457da7720d6884cf459f39545002ff7c5c8afb9f6fd6bbbe089890a10f483e679d831a0afef0559fd9fc3
EBUILD clang-runtime-20.0.0.9999.ebuild 1339 BLAKE2B 4a5ee8a332faf2da21256df048867b1458a5ccb2d733d00ee3788bfbc28b3daf4ce2ae2455ab03c9ebb192d964feae2cd5806b5fef23eaa9401d57b35386aa57 SHA512 fac3e259b5a7b5e105b3d5fd2f8e9a9b6236642867e4c4a67106ec999dfaf0a30a97a3905685043a0ab9f38b15b7b8a5a814a97921e37029b9d0beac7ba7085a
EBUILD clang-runtime-20.0.0_pre20240917.ebuild 1339 BLAKE2B 4a5ee8a332faf2da21256df048867b1458a5ccb2d733d00ee3788bfbc28b3daf4ce2ae2455ab03c9ebb192d964feae2cd5806b5fef23eaa9401d57b35386aa57 SHA512 fac3e259b5a7b5e105b3d5fd2f8e9a9b6236642867e4c4a67106ec999dfaf0a30a97a3905685043a0ab9f38b15b7b8a5a814a97921e37029b9d0beac7ba7085a
EBUILD clang-runtime-20.0.0_pre20240924.ebuild 1339 BLAKE2B 4a5ee8a332faf2da21256df048867b1458a5ccb2d733d00ee3788bfbc28b3daf4ce2ae2455ab03c9ebb192d964feae2cd5806b5fef23eaa9401d57b35386aa57 SHA512 fac3e259b5a7b5e105b3d5fd2f8e9a9b6236642867e4c4a67106ec999dfaf0a30a97a3905685043a0ab9f38b15b7b8a5a814a97921e37029b9d0beac7ba7085a
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.1.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.1.ebuild
new file mode 100644
index 000000000000..8ded193c919c
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-19.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}