summaryrefslogtreecommitdiff
path: root/sys-devel/crosstool-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-07 00:11:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-07 00:11:16 +0000
commit1b2360e7bab42e4045232887cb4f6c4a24ca3975 (patch)
tree6a5a60c4c59058ef39895ea69fb8e98eaa49aed8 /sys-devel/crosstool-ng
parent22eaa60297c2dbc92dd1658fb7d8e46878552755 (diff)
gentoo auto-resync : 07:02:2025 - 00:11:15
Diffstat (limited to 'sys-devel/crosstool-ng')
-rw-r--r--sys-devel/crosstool-ng/Manifest4
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-1.27.0.ebuild84
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-9999.ebuild13
3 files changed, 91 insertions, 10 deletions
diff --git a/sys-devel/crosstool-ng/Manifest b/sys-devel/crosstool-ng/Manifest
index 1861cb62f44c..30c1e31da286 100644
--- a/sys-devel/crosstool-ng/Manifest
+++ b/sys-devel/crosstool-ng/Manifest
@@ -1,4 +1,6 @@
DIST crosstool-ng-1.26.0.tar.xz 1144720 BLAKE2B 68c38dca58a239bd2a7a4e0f0adfa0069d97aba632c8a8a70594a67bf1049f0576db2d20b8a6ac90b170c1a3d8245f952a949e4fd006abe1d5e54effbb8e100b SHA512 7834184ae5792fd347455f9f48fee826248dcb82d271954ed4304b1a18f63995ff8a2c3b817564dcf147ac7e16e02d779195b26d97eb57db27f1118a1837002a
+DIST crosstool-ng-1.27.0.tar.xz 1163084 BLAKE2B 6f9c7e16a6bdccbfd31fd7839df59878deedf193251ef0896bfde79b9b844646b83316fdaf26ca826377375cc36f77e6ddf6503c10ca30dbcf9d9086b3272830 SHA512 2201106561a199ebaddd238ed5158f62f63787333b87d2692aa726ad21bc90b08483deed7257fc35af995e355cfb567d7550b5ea171259ec5a0e0c3bee3b3ca2
EBUILD crosstool-ng-1.26.0-r1.ebuild 1715 BLAKE2B 13d4fc08a83bc2bfed5f7f20fb11c81c20c0e1e584798a37953037f909dd954cc7ffb34e04b782be07fb8cdd83a0a88b0cdaf6751cd170c06ef5ce8244b7dd5c SHA512 495b9002de96e19b98b9cc635d7d86ac16d2ad04e1a73aaf088ea25530a175625add3940cc45f9f1514edb400f03f744f2e53ee818e0c3c2e8b5764cbc2dfd0d
-EBUILD crosstool-ng-9999.ebuild 2152 BLAKE2B c6bc736dbf5019427043d79c37dfaf4401e410f60059fa9e0ed53d8c408185091d88515ea5960f284ae139ba8911ffa0aa8dd14f947f260c9c485c8e8b254a46 SHA512 e845065fd4d1b7610b7fc7ae5c35c5761308861578728d3b89eb9f538c457e72df7eaedbc278bc4edc048c7894ef74a87b5d2e3e6ffc555db2ddeb504c718054
+EBUILD crosstool-ng-1.27.0.ebuild 2018 BLAKE2B 200e1babd59ef3285bd5ba5a0fc7e56f42f008ccee8108041b7461b5599bf7c18d86357ab85d7fc9fffa861b4a5f9a12470269a405c1f17b8c18591fc4ba1ba0 SHA512 f0cdea868cfc3ea30471493d37976da721903eca33cd970b0ca7b846b8d17221ef2603957c0456966f38a1511fae3c8c346dc79dcabf3e2b40608415b71b2dd7
+EBUILD crosstool-ng-9999.ebuild 2018 BLAKE2B 200e1babd59ef3285bd5ba5a0fc7e56f42f008ccee8108041b7461b5599bf7c18d86357ab85d7fc9fffa861b4a5f9a12470269a405c1f17b8c18591fc4ba1ba0 SHA512 f0cdea868cfc3ea30471493d37976da721903eca33cd970b0ca7b846b8d17221ef2603957c0456966f38a1511fae3c8c346dc79dcabf3e2b40608415b71b2dd7
MISC metadata.xml 973 BLAKE2B e910f49277500ae3bebdd7307c8e6bce9cf8b16e968790c308c08678da2742ce04aae68b6fef00af59c4f56ecfbf6a1ed1a7a255d7c78925af30e0ecd22195a1 SHA512 012a54cb5bac5775dd0f7ea8980a8422a108d3447ec34386ca5c1d2fd5bb996e22e2a683a66b401822ccf59aee864580066c97d3d6b85c797373223c68e47379
diff --git a/sys-devel/crosstool-ng/crosstool-ng-1.27.0.ebuild b/sys-devel/crosstool-ng/crosstool-ng-1.27.0.ebuild
new file mode 100644
index 000000000000..2a0c5d8f9e91
--- /dev/null
+++ b/sys-devel/crosstool-ng/crosstool-ng-1.27.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit python-single-r1
+
+DESCRIPTION="Versatile (cross-)toolchain generator"
+HOMEPAGE="https://crosstool-ng.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/crosstool-ng/crosstool-ng.git"
+ inherit autotools git-r3
+else
+ SRC_URI="
+ https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
+ http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
+ "
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-2 doc? ( CC-BY-SA-2.5 )"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="curl cvs doc dtc git lzip meson ninja python rsync subversion wget"
+
+# TODO: Consider dropping these USE (optfeature), but configure does check for them
+BDEPEND="
+ app-arch/unzip
+ >=app-shells/bash-3.1
+ sys-apps/help2man
+ >=sys-apps/sed-4.0
+ sys-apps/gawk
+ sys-apps/texinfo
+ sys-apps/which
+ sys-devel/bison
+ sys-devel/flex
+ curl? ( net-misc/curl )
+ cvs? ( dev-vcs/cvs )
+ dtc? ( sys-apps/dtc )
+ git? ( dev-vcs/git )
+ lzip? ( app-arch/lzip )
+ meson? ( dev-build/meson )
+ python? ( ${PYTHON_DEPS} )
+ ninja? ( app-alternatives/ninja )
+ rsync? ( net-misc/rsync )
+ subversion? ( dev-vcs/subversion )
+ wget? ( net-misc/wget )
+"
+RDEPEND="
+ ${BDEPEND}
+"
+
+src_prepare() {
+ if [[ ${PV} == 9999 ]]; then
+ # Some data files must be generated before autoreconf, and the logic
+ # is non-trivial, so the upstream bootstrap script must be used.
+ # In addition, eautoreconf mis-detects the project to make use of
+ # gettext while it actually isn't, so just rely on the invocation of
+ # autoreconf for us in the bootstrap script.
+ ./bootstrap || die "bootstrap failed"
+ fi
+
+ default
+}
+
+src_configure() {
+ # Needs bison+flex
+ unset YACC LEX
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -f "${ED}"/usr/share/man/man1/ct-ng.1.gz || die
+ doman docs/ct-ng.1
+}
diff --git a/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild b/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild
index 78700c65fe2d..2a0c5d8f9e91 100644
--- a/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild
+++ b/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit python-single-r1
DESCRIPTION="Versatile (cross-)toolchain generator"
@@ -73,17 +73,12 @@ src_configure() {
# Needs bison+flex
unset YACC LEX
- default
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
}
src_install() {
emake DESTDIR="${D}" install
- if use doc ; then
- mv "${ED}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} "${ED}"/usr/share/doc/ || die
- fi
-
- rm -rf "${ED}"/usr/share/doc/crosstool-ng || die
- rm -rf "${ED}"/usr/share/man/man1/ct-ng.1.gz || die
+ rm -f "${ED}"/usr/share/man/man1/ct-ng.1.gz || die
doman docs/ct-ng.1
}