summaryrefslogtreecommitdiff
path: root/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-devel/ct-ng/ct-ng-1.23.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-devel/ct-ng/ct-ng-1.23.0.ebuild')
-rw-r--r--sys-devel/ct-ng/ct-ng-1.23.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/ct-ng-1.23.0.ebuild b/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
new file mode 100644
index 000000000000..42a61e626953
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+S="${WORKDIR}/crosstool-ng-${PV}"
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}