summaryrefslogtreecommitdiff
path: root/sys-devel/flex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-devel/flex
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-devel/flex')
-rw-r--r--sys-devel/flex/Manifest1
-rw-r--r--sys-devel/flex/flex-2.6.4-r2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-devel/flex/Manifest b/sys-devel/flex/Manifest
index 37568bc5f954..716c6c7d4367 100644
--- a/sys-devel/flex/Manifest
+++ b/sys-devel/flex/Manifest
@@ -2,4 +2,5 @@ AUX flex-2.6.4-fix-build-with-glibc2.6+.patch 20281 BLAKE2B 859e15a65473a74635db
AUX flex-2.6.4-libobjdir.patch 770 BLAKE2B 0771af247117123e3efed3e2a0c8a71573c81dc1e8d2e364a887aa49d3bf3a5198042396d1df1e2c0ae196df098241eba0e2b35e953f9a5be3d43d2408a97536 SHA512 76e3a3e19fe9c9b6b3e0fcfea98feb0eaf03fdc683e3695045b3246b57538a52842b455a9aebed87548d2b8ee3e7d34dca5ff355f06648911866b3b621b40f86
DIST flex-2.6.4.tar.gz 1419096 BLAKE2B c003d4f764f7f4d41e33af7ee28c2af272a9f0aee6ba7c2494ba96722d8d0b18f7a3f745217e9a2cecb43b6863328267a810280670c04464156b3eb3d7ee9d62 SHA512 e9785f3d620a204b7d20222888917dc065c2036cae28667065bf7862dfa1b25235095a12fd04efdbd09bfd17d3452e6b9ef953a8c1137862ff671c97132a082e
EBUILD flex-2.6.4-r1.ebuild 2022 BLAKE2B 82ba69679aa66e9e66a3e36c037e01902394f9f99e2e057477e3c3f30f5c55a9c0a6c52c69d3a6d6df118f0cbac0c95500e04d17ec01481baf64c7997287d588 SHA512 e25615e3b8f985e07d0c0c6175467484ba09c817e411eb0cb2d30da6ecb036a316745270def159c9e294af506115adcf1c7e0ceb1aa267f2fa280d1ffc1d7d09
+EBUILD flex-2.6.4-r2.ebuild 2334 BLAKE2B 6a23e80583bb9ddde0b1aa0a9a4d69e1b2b1fb72d5c78db552e4d2092639773712f0e3a31d687a5d99abfea6efbe058dcb3d31c73e4f6fa9e8a65cd5a8316b18 SHA512 78682dde4e83805ed87cfc7c9e789d03b010afd9d92c4734ecd2e54c56bc72f0fca7d2806017898fe384d4171fd0354b86669a36e9d00862b20c016af334b243
MISC metadata.xml 444 BLAKE2B 28bd0cd35c6ab4386dffdf221e6b43927e47971bea62a0f0395e3cd6725567114675055dc1267ce5ffbd42fe4731a806b4e5666ea6b83ad4bcf4d35b5529ce85 SHA512 53f91d714d7f4401f7d986d743c08a817d794147f9b277d829a4e8065ce91ce00123cd5b42957af60ef9051568a214b7ce791aa8a4baf82a5179859971357d56
diff --git a/sys-devel/flex/flex-2.6.4-r2.ebuild b/sys-devel/flex/flex-2.6.4-r2.ebuild
new file mode 100644
index 000000000000..b1e13e873c6d
--- /dev/null
+++ b/sys-devel/flex/flex-2.6.4-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool multilib-minimal toolchain-funcs
+
+DESCRIPTION="The Fast Lexical Analyzer"
+HOMEPAGE="https://github.com/westes/flex"
+SRC_URI="https://github.com/westes/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="FLEX"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static test"
+RESTRICT="!test? ( test )"
+
+# We want bison explicitly and not yacc in general, bug #381273
+RDEPEND="sys-devel/m4"
+BDEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( sys-devel/bison )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.4-libobjdir.patch
+ "${FILESDIR}"/${PN}-2.6.4-fix-build-with-glibc2.6+.patch
+)
+
+src_prepare() {
+ default
+
+ # Disable running in the tests/ subdir as it has a bunch of built sources
+ # that cannot be made conditional (automake limitation). bug #568842
+ if ! use test ; then
+ sed -i \
+ -e '/^SUBDIRS =/,/^$/{/tests/d}' \
+ Makefile.in || die
+ fi
+
+ # Prefix always needs this
+ elibtoolize
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ if tc-is-cross-compiler ; then
+ # Similar to workaround for procps:
+ # - bug #705800
+ # - https://sourceforge.net/p/psmisc/bugs/71/
+ # - https://lists.gnu.org/archive/html/autoconf/2011-04/msg00019.html
+ export ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
+ fi
+
+ # Do not install shared libs, #503522
+ ECONF_SOURCE="${S}" econf \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ --disable-shared \
+ $(use_enable nls)
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C src -f Makefile -f - lib <<< 'lib: $(lib_LTLIBRARIES)'
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && emake check
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C src DESTDIR="${D}" install-libLTLIBRARIES install-includeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc ONEWS
+ find "${ED}" -name '*.la' -type f -delete || die
+ rm "${ED}"/usr/share/doc/${PF}/COPYING || die
+
+ dosym flex /usr/bin/lex
+}