summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-10.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 07:02:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 07:02:03 +0000
commitc4f077d9f57bf57fcded75904bf512075191d2d2 (patch)
tree028f6c50f859c521d2b2093e314e95e4f5a8e98a /sys-devel/kgcc64/kgcc64-10.3.0.ebuild
parent5d0c0ffd63620a4db788484bd36ab92b76e7891b (diff)
gentoo auto-resync : 20:11:2022 - 07:02:03
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-10.3.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-10.3.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-devel/kgcc64/kgcc64-10.3.0.ebuild b/sys-devel/kgcc64/kgcc64-10.3.0.ebuild
deleted file mode 100644
index 3eb8d3aeded9..000000000000
--- a/sys-devel/kgcc64/kgcc64-10.3.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-case ${CHOST} in
- hppa*) CTARGET=hppa64-${CHOST#*-};;
- mips*) CTARGET=${CHOST/mips/mips64};;
- powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
- s390*) CTARGET=${CHOST/s390/s390x};;
- sparc*) CTARGET=${CHOST/sparc/sparc64};;
- i?86*) CTARGET=x86_64-${CHOST#*-};;
-esac
-export CTARGET
-TOOLCHAIN_ALLOWED_LANGS="c"
-TOOLCHAIN_PATCH_DEV="slyfox"
-GCC_TARGET_NO_MULTILIB=true
-
-PATCH_VER="1"
-inherit toolchain
-
-DESCRIPTION="64bit kernel compiler"
-
-# Works on hppa and mips; all other archs, refer to bug #228115
-KEYWORDS="hppa"
-
-# unlike every other target, hppa has not unified the 32/64 bit
-# ports in binutils yet
-DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
-
-pkg_postinst() {
- toolchain_pkg_postinst
-
- cd "${ROOT}"/usr/bin
- local x
- for x in gcc cpp ; do
- cat <<-EOF >${CTARGET%%-*}-linux-${x}
- #!/bin/sh
- exec ${CTARGET}-${x} "\$@"
- EOF
- chmod a+rx ${CTARGET%%-*}-linux-${x}
- done
-}