summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-22 14:47:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-22 14:47:12 +0100
commit1802160f23e91c618b3c7379fd99127682cfce19 (patch)
tree094c5349b2f0bd88633709f2f1ad322398475815 /sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild
parent439c34b3917f0757b9c83eb64a687cac0d477140 (diff)
gentoo auto-resync : 22:09:2024 - 14:47:12
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild b/sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild
new file mode 100644
index 000000000000..906cc3f5c5e3
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-13.3.1_p20240920.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_VER="18"
+PATCH_GCC_VER="13.2.0"
+MUSL_VER="2"
+MUSL_GCC_VER="13.2.0"
+GCC_TARGET_NO_MULTILIB=true
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+BDEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}