summaryrefslogtreecommitdiff
path: root/sys-devel/libtool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
commitc6985b401141ea8b5ec4b95c4ad3a5a21ef32571 (patch)
tree56249d49d47e3dde9d3298ed175d983defedf23b /sys-devel/libtool
parent6790f1eddc7029fda1a6bae94751a4ff1eb57776 (diff)
gentoo auto-resync : 09:01:2024 - 13:01:22
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/Manifest3
-rw-r--r--sys-devel/libtool/libtool-2.4.7-r2.ebuild116
-rw-r--r--sys-devel/libtool/libtool-9999.ebuild3
3 files changed, 119 insertions, 3 deletions
diff --git a/sys-devel/libtool/Manifest b/sys-devel/libtool/Manifest
index 92963a2c92de..9b3da1f47b5c 100644
--- a/sys-devel/libtool/Manifest
+++ b/sys-devel/libtool/Manifest
@@ -9,5 +9,6 @@ AUX libtool-2.4.7-grep-3.8.patch 1282 BLAKE2B b64b6eab6bed4b5595ef228c9d3bc65a8b
AUX libtool-2.4.7-werror-lto.patch 2248 BLAKE2B 3537c599ee310fda695b1a671770e1d2c5a943e763641515738e8d13907b807b92727182a34af4c20598c3ad228a2b660f10fd582c2f65d1fdef11b92f5fc68a SHA512 b16f835fbec1ecf6c8408c0705fc94886f35443394298e9ae1d1893dbf7dbad11325b636ccc9d0ddeecc00a13a7b5ae78867dd1369b0fc2fcd9276808f326146
DIST libtool-2.4.7.tar.xz 1016040 BLAKE2B 5e022586337637dd634bd40578ad944bec6e3b8de41f95d55777b90cc88cbc4badb3d76cbf0e638166ece1ea7de828e83590e1e6bac30c1e4b1c254a11a742f2 SHA512 47f4c6de40927254ff9ba452612c0702aea6f4edc7e797f0966c8c6bf0340d533598976cdba17f0bdc64545572e71cd319bbb587aa5f47cd2e7c1d96f873a3da
EBUILD libtool-2.4.7-r1.ebuild 3328 BLAKE2B 3ee8c1f44bc8d9ab04a65e7653459bfe8660013f504b01c097966e966e6274ce9fdd72664142803aee456a66e75e1eb373a17d5f0f727ccb9b522ae45f3152fc SHA512 72a6891c77b3c84173ad0dccc2a2826ae500e275c8c6fcb2eb2e8c2c553890f96cff6a69a30db1e5493a9e54d1c06c31c7873965e4eb7cab6c1e79476064b078
-EBUILD libtool-9999.ebuild 3292 BLAKE2B 0e27f5acd9191f0ed43a5cc2f0c72282f06aa773c11db4b9bc973b70544f554a5c76816df307fa7d5800484885b47ad6f24636d02ffc3e62fe280bd7474bdffe SHA512 27e561b9c2f23a6e7ffef9cdf4b0cb8206d94737bf48385dfb97bb41f1dcf59a9f61244f190d86c4352e19ff2e23f2d4ff21f6afe30a481d543d8346dda78b41
+EBUILD libtool-2.4.7-r2.ebuild 3310 BLAKE2B 13c66147ee4e1b88bbef84033b7650dd2da583e63db0bfd9f5bac79f43f56e6c3e17579dfc0710801be368e141f53563eadddbcebbb82c8eb04aba7fb0ec6bb3 SHA512 5eb8d74af9a0935e4b910292a6384bc5244168d35c031c7c41e6881f5743b2f73817081e95ca52310e2d6de06adcfafdb85493a89ae6d0e7dfad36c415cf2de4
+EBUILD libtool-9999.ebuild 3266 BLAKE2B d05da6e4f8ba6a6719f9db2eeb5efe24998415f778698467d1bfee46ef8c21735150e0eca8d340db6a787fa341728c7b0db456df0dfb3333f1666ebcfd012739 SHA512 469dca6ab3b94723310586e03d59556bb7838e9861afb00874d83fa40996a7541148e4f62702dd987201d23f99cd2b29a76b896898bc86241932e3af0a30aba0
MISC metadata.xml 331 BLAKE2B 4a4cfaad20b2f1c22b0b5ab23b4557e1bef50dbc49d0b7d821d4099e06bf488fdc6c7cb4a29431910d0e1b8cfb7c8b565cd3296afb30925a08389e023c777150 SHA512 9ca8e937181de31beb06558475dc8c10e61765d5280a882576a2d1e4e87fb750bc1c2e99aafdfffe343343797e0565814c0a5f8c18c7fba5b7fe9275100f2609
diff --git a/sys-devel/libtool/libtool-2.4.7-r2.ebuild b/sys-devel/libtool/libtool-2.4.7-r2.ebuild
new file mode 100644
index 000000000000..2bf9e471c863
--- /dev/null
+++ b/sys-devel/libtool/libtool-2.4.7-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Please bump with dev-libs/libltdl.
+
+# bug #225559
+LIBTOOLIZE="true"
+WANT_LIBTOOL="none"
+inherit autotools prefix
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/libtool.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="https://www.gnu.org/software/libtool/"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="vanilla"
+
+# Pull in libltdl directly until we convert packages to the new dep.
+RDEPEND="
+ sys-devel/gnuconfig
+ >=sys-devel/autoconf-2.69:*
+ >=sys-devel/automake-1.13:*
+"
+DEPEND="${RDEPEND}"
+[[ ${PV} == *9999 ]] && BDEPEND="sys-apps/help2man"
+
+PATCHES=(
+ # bug #109105
+ "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch
+ # bug #581314
+ "${FILESDIR}"/${PN}-2.4.6-ppc64le.patch
+
+ "${FILESDIR}"/${PN}-2.2.6a-darwin-module-bundle.patch
+ "${FILESDIR}"/${PN}-2.4.6-darwin-use-linux-version.patch
+ "${FILESDIR}"/${PN}-2.4.7-werror-lto.patch
+ "${FILESDIR}"/${PN}-2.4.7-grep-3.8.patch
+)
+
+src_prepare() {
+ if [[ ${PV} == *9999 ]] ; then
+ eapply "${FILESDIR}"/${PN}-2.4.6-pthread.patch # bug #650876
+ ./bootstrap || die
+ else
+ PATCHES+=(
+ "${FILESDIR}"/${PN}-2.4.6-pthread_bootstrapped.patch # bug #650876
+ )
+ fi
+
+ # WARNING: File build-aux/ltmain.sh is read-only; trying to patch anyway
+ chmod +w build-aux/ltmain.sh || die
+
+ if use vanilla ; then
+ eapply_user
+ return 0
+ else
+ default
+ fi
+
+ if use prefix ; then
+ # seems that libtool has to know about EPREFIX a little bit
+ # better, since it fails to find prefix paths to search libs
+ # from, resulting in some packages building static only, since
+ # libtool is fooled into thinking that libraries are unavailable
+ # (argh...). This could also be fixed by making the gcc wrapper
+ # return the correct result for -print-search-dirs (doesn't
+ # include prefix dirs ...).
+ eapply "${FILESDIR}"/${PN}-2.2.10-eprefix.patch
+ eprefixify m4/libtool.m4
+ fi
+
+ pushd libltdl >/dev/null || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ popd >/dev/null || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+
+ # Make sure timestamps don't trigger a rebuild of man pages. #556512
+ if [[ ${PV} != *9999 ]] ; then
+ touch doc/*.1 || die
+ export HELP2MAN=true
+ fi
+}
+
+src_configure() {
+ # the libtool script uses bash code in it and at configure time, tries
+ # to find a bash shell. if /bin/sh is bash, it uses that. this can
+ # cause problems for people who switch /bin/sh on the fly to other
+ # shells, so just force libtool to use /bin/bash all the time.
+ export CONFIG_SHELL="$(type -P bash)"
+
+ # Do not bother hardcoding the full path to sed.
+ # Just rely on $PATH. bug #574550
+ export ac_cv_path_SED="$(basename "$(type -P sed)")"
+
+ [[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"
+
+ ECONF_SOURCE="${S}" econf ${myconf} --disable-ltdl-install
+}
+
+src_install() {
+ default
+
+ local x
+ while read -d $'\0' -r x ; do
+ ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
+ done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
+}
diff --git a/sys-devel/libtool/libtool-9999.ebuild b/sys-devel/libtool/libtool-9999.ebuild
index a27b9abcb010..ae63801bea83 100644
--- a/sys-devel/libtool/libtool-9999.ebuild
+++ b/sys-devel/libtool/libtool-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,6 @@ RDEPEND="
sys-devel/gnuconfig
>=sys-devel/autoconf-2.69:*
>=sys-devel/automake-1.13:*
- >=dev-libs/libltdl-2.4.7
"
DEPEND="${RDEPEND}"
[[ ${PV} == *9999 ]] && BDEPEND="sys-apps/help2man"