summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-11.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-devel/llvm-common/llvm-common-11.1.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-11.1.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-11.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-11.1.0.ebuild b/sys-devel/llvm-common/llvm-common-11.1.0.ebuild
new file mode 100644
index 000000000000..c332f7dbbd1d
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-11.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}