summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-16.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
commit2de9aaae9b6018544ada7f67e2229605e1ec4d04 (patch)
tree231bad5690196ca522285d446614a065879cc7d0 /sys-devel/llvm-common/llvm-common-16.0.1.ebuild
parent4274bed0c1f1fd06a654f5816e30d82059f4cc39 (diff)
gentoo auto-resync : 05:04:2023 - 23:26:20
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-16.0.1.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-16.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-16.0.1.ebuild b/sys-devel/llvm-common/llvm-common-16.0.1.ebuild
new file mode 100644
index 000000000000..4dd4fe395fe7
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-16.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}