summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-16.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-27 11:30:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-27 11:30:42 +0100
commitddb6fbc11e863756a24e1dc866c63dec00eac6fa (patch)
tree697bafc13819641c0cb81d469945e2a773adca86 /sys-devel/llvm/llvm-16.0.6.ebuild
parente466209c898f09389f2308d193286ff62b46c1dc (diff)
gentoo auto-resync : 27:09:2023 - 11:30:42
Diffstat (limited to 'sys-devel/llvm/llvm-16.0.6.ebuild')
-rw-r--r--sys-devel/llvm/llvm-16.0.6.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-16.0.6.ebuild b/sys-devel/llvm/llvm-16.0.6.ebuild
index ae2efdaf8280..d6cb84f6df61 100644
--- a/sys-devel/llvm/llvm-16.0.6.ebuild
+++ b/sys-devel/llvm/llvm-16.0.6.ebuild
@@ -425,6 +425,13 @@ multilib_src_configure() {
)
fi
+ # On Macos prefix, Gentoo doesn't split sys-libs/ncurses to libtinfo and
+ # libncurses, but llvm tries to use libtinfo before libncurses, and ends up
+ # using libtinfo (actually, libncurses.dylib) from system instead of prefix
+ use kernel_Darwin && mycmakeargs+=(
+ -DTerminfo_LIBRARIES=-lncurses
+ )
+
# workaround BMI bug in gcc-7 (fixed in 7.4)
# https://bugs.gentoo.org/649880
# apply only to x86, https://bugs.gentoo.org/650506