summaryrefslogtreecommitdiff
path: root/sys-devel/nvptx-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-30 02:06:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-30 02:06:22 +0000
commit080d89feff80cae2fc974ff2f24d463141c20635 (patch)
tree53d0a66fabd88f847940192be8163c5f3291d434 /sys-devel/nvptx-tools
parent2a3c08f4647671d17f534a5dbd8bd45e11c90ea2 (diff)
gentoo auto-resync : 30:11:2024 - 02:06:22
Diffstat (limited to 'sys-devel/nvptx-tools')
-rw-r--r--sys-devel/nvptx-tools/Manifest2
-rw-r--r--sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/nvptx-tools/Manifest b/sys-devel/nvptx-tools/Manifest
index 9d0f1e3733bc..f6c2b619a185 100644
--- a/sys-devel/nvptx-tools/Manifest
+++ b/sys-devel/nvptx-tools/Manifest
@@ -1,4 +1,6 @@
DIST nvptx-tools-0_pre20230122.tar.gz 789116 BLAKE2B f05b922827c0215a2484c4f91f3424ca866bb91435a3d60559fc9f1f63c06559377f1c8071c9e8e5607ec4dbff1c22d095385ac86d35f43ade29d9df6699f3ff SHA512 9d3bceef2ef7942ea6ec8b6c6b1b9144f0a020bfabc2583ba4ef73db8ef299ffadbc6dbe27748c728bd16aee0ecd6f0fbe1f8bb064bde986bb4e0475b2494870
+DIST nvptx-tools-0_pre20240809.tar.gz 994915 BLAKE2B eef94a55d4ec48fb3031e20d5722e4f0564e7ed5ddc217a0b88d15236d9c15bbd60d14ab537e3535c40e800d75578c21833c6f414bdf11f0fed6f7eb3721478a SHA512 b98ee6f045ec820d056ce7cf4af4d3dcabdd0e77d15f02a88dd3e7f60de6ec32ecb454787f1ef626e358cde7744c5635f8d2e8ff78b46a714f627a37ac256ddb
EBUILD nvptx-tools-0_pre20230122.ebuild 1188 BLAKE2B 7b468ef5479c0bf8c1d552f2756598d8402d3d72653719855f8e7ad76d26c00952a7498d3d114204b1cad2b5023721ec261717bbe2f6fb59a1a80d3e291b441e SHA512 fbac3ab468f70200e1e14c2cd41de8545998ee6dd4f791c25d20fd58829017fb85854acd1342223a2a381b467cc6dd4c1ff57beeb10601f674cf86895210a56d
+EBUILD nvptx-tools-0_pre20240809.ebuild 1193 BLAKE2B 5408e67cf7d7ce2dba5ad01ec9b0ada7391db3a37a938ff4e3746b6e03439db1eb99f7332f426f81fec9709a29e8dc12d397f2ffa683da7d73711a2b260bdd45 SHA512 d690f2a67b70aaaa249fa30d7298d87155ab04dadb0bc2eeefc7ff5852ea87f41d69eb505b3005303d588d085b8f10dbb28c4acfff7a8fb7295730735b702bdc
EBUILD nvptx-tools-9999.ebuild 1188 BLAKE2B 7b468ef5479c0bf8c1d552f2756598d8402d3d72653719855f8e7ad76d26c00952a7498d3d114204b1cad2b5023721ec261717bbe2f6fb59a1a80d3e291b441e SHA512 fbac3ab468f70200e1e14c2cd41de8545998ee6dd4f791c25d20fd58829017fb85854acd1342223a2a381b467cc6dd4c1ff57beeb10601f674cf86895210a56d
MISC metadata.xml 352 BLAKE2B 8dcbda9f328d426459c543132a16db279e1a465f7d326c40b6226019a29f2f424109f000bd8de621ae1f76dc85d6e29a8b3609cd716387265edc776ff5a08d62 SHA512 74343cb4485819287ddf2eab706647f373d6fb574b0a6ebe52b6cafa391185da583aad6a669872d0e4132b64afd3fb84b511cbd8091986c10ec3939e2c25abed
diff --git a/sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild b/sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild
new file mode 100644
index 000000000000..e76b4259f828
--- /dev/null
+++ b/sys-devel/nvptx-tools/nvptx-tools-0_pre20240809.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of tools for use with nvptx-none GCC toolchains"
+HOMEPAGE="https://github.com/SourceryTools/nvptx-tools https://gcc.gnu.org/wiki/nvptx"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/SourceryTools/nvptx-tools"
+ inherit git-r3
+else
+ MY_COMMIT="a0c1fff6534a4df9fb17937c3c4a4b1071212029"
+ SRC_URI="https://github.com/SourceryTools/nvptx-tools/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+BDEPEND="
+ test? (
+ dev-python/lit
+ dev-util/dejagnu
+ )
+"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ # Reject newlib-on-glibc type installs
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ case ${CHOST} in
+ *-newlib|nvptx-*) ;;
+ *) die "Use sys-devel/crossdev to build a nvptx(-none) toolchain" ;;
+ esac
+ fi
+}