summaryrefslogtreecommitdiff
path: root/sys-devel/sparse/sparse-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /sys-devel/sparse/sparse-9999.ebuild
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'sys-devel/sparse/sparse-9999.ebuild')
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 8771de72828a..aad07d85db73 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,26 +1,23 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
inherit eutils multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
- inherit git-2
-fi
DESCRIPTION="C semantic parser"
HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- #KEYWORDS=""
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+ KEYWORDS=""
else
- SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.xz"
+ SRC_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git/snapshot/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
-LICENSE="OSL-1.1"
+LICENSE="MIT"
SLOT="0"
IUSE="gtk llvm test xml"
@@ -31,15 +28,18 @@ DEPEND="${RDEPEND}
gtk? ( virtual/pkgconfig )
xml? ( virtual/pkgconfig )"
+PATCHES=( "${FILESDIR}/${PN}-0.5.1-cmdline-include.patch" )
+
src_prepare() {
tc-export AR CC PKG_CONFIG
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
- -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e '/^COMMON_CFLAGS =/{s:=:= $(CPPFLAGS):;s:-O2 -finline-functions -fno-strict-aliasing -g:-fno-strict-aliasing:}' \
-e "s:pkg-config:${PKG_CONFIG}:" \
Makefile || die
export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
+ default
}
src_compile() {