summaryrefslogtreecommitdiff
path: root/sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-07 04:34:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-07 04:34:29 +0100
commit1ccef27203b03f1fa900c9b44dc425df27e49452 (patch)
tree9c98577fb64ec98520e2d39857ab6f917e8fa460 /sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild
parentc4b3d05f2d4415c0d6f135a3ea0d2055d6e055b5 (diff)
gentoo auto-resync : 07:09:2022 - 04:34:29
Diffstat (limited to 'sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild')
-rw-r--r--sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild b/sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild
new file mode 100644
index 000000000000..7b35ffe6dc9e
--- /dev/null
+++ b/sys-firmware/edk2-ovmf-bin/edk2-ovmf-bin-202202.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+BINPKG="${P/-bin/}-1"
+
+DESCRIPTION="UEFI firmware for 64-bit x86 virtual machines"
+HOMEPAGE="https://github.com/tianocore/edk2"
+SRC_URI="https://dev.gentoo.org/~ajak/distfiles/${BINPKG}.xpak"
+S="${WORKDIR}"
+
+# TODO: the binary 202105 package currently lacks the preseeded
+# OVMF_VARS.secboot.fd file (that we typically get from fedora)
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+#KEYWORDS="~amd64 ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="!sys-firmware/edk2-ovmf"
+
+DISABLE_AUTOFORMATTING=true
+DOC_CONTENTS="This package contains the tianocore edk2 UEFI firmware for 64-bit x86
+virtual machines. The firmware is located under
+ /usr/share/edk2-ovmf/OVMF_CODE.fd
+ /usr/share/edk2-ovmf/OVMF_VARS.fd
+ /usr/share/edk2-ovmf/OVMF_CODE.secboot.fd
+
+If USE=binary is enabled, we also install an OVMF variables file (coming from
+fedora) that contains secureboot default keys
+
+ /usr/share/edk2-ovmf/OVMF_VARS.secboot.fd
+
+If you have compiled this package by hand, you need to either populate all
+necessary EFI variables by hand by booting
+ /usr/share/edk2-ovmf/UefiShell.(iso|img)
+or creating OVMF_VARS.secboot.fd by hand:
+ https://github.com/puiterwijk/qemu-ovmf-secureboot
+
+The firmware does not support csm (due to no free csm implementation
+available). If you need a firmware with csm support you have to download
+one for yourself. Firmware blobs are commonly labeled
+ OVMF{,_CODE,_VARS}-with-csm.fd
+
+In order to use the firmware you can run qemu the following way
+
+ $ qemu-system-x86_64 \
+ -drive file=/usr/share/edk2-ovmf/OVMF.fd,if=pflash,format=raw,unit=0,readonly=on \
+ ..."
+
+src_unpack() {
+ tar -x < <(xz -c -d --single-stream "${DISTDIR}/${BINPKG}.xpak") || die "unpacking binpkg failed"
+}
+
+src_install() {
+ mv "usr/share/doc/${P/-bin/}" "usr/share/doc/${PF}" || die
+
+ # Don't want to try to install the readme from the source package
+ rm "usr/share/doc/${PF}/README.gentoo.bz2"
+ mv usr "${ED}" || die
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}