summaryrefslogtreecommitdiff
path: root/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild')
-rw-r--r--sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild b/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
new file mode 100644
index 000000000000..263933596f93
--- /dev/null
+++ b/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DEB_VER=6.2
+DESCRIPTION="edit disk partitions on Acorn machines"
+HOMEPAGE="http://www.arm.linux.org.uk/"
+SRC_URI="ftp://ftp.arm.linux.org.uk/pub/armlinux/source/other/${P}.tar.gz
+ mirror://debian/pool/main/a/acorn-fdisk/acorn-fdisk_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/acorn-fdisk_${PV}-${DEB_VER}.diff
+
+ find "${S}" -name Makefile -print0 | xargs -0 \
+ sed -i \
+ -e "s:-O2 -Wall\( -g\)\?::" \
+ -e "/^CFLAGS/s:=:+=:" \
+ -e "/^LDFLAGS/s:=:+=:" \
+ -e '/^STRIP/s:strip:true:'
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" || die
+}
+
+src_install() {
+ into /
+ newsbin fdisk ${PN} || die "sbin failed"
+ dosym ${PN} /sbin/acorn-fdisk
+ dodoc ChangeLog README debian/changelog
+}