summaryrefslogtreecommitdiff
path: root/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-28 10:02:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-28 10:02:11 +0100
commit9967860c0cd26c0940ee4b9ab6698e00e5b1260a (patch)
tree000be053853792419070a7d8f64379ec7ca7bc8b /sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
parentefc1a67ef36757bc76eb899ec03802086adda461 (diff)
gentoo auto-resync : 28:08:2023 - 10:02:11
Diffstat (limited to 'sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild')
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
index 3e057d19c8ff..e0dd0d66a627 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
@@ -23,7 +23,7 @@ if [[ ${PV} == "9999" ]]; then
else
MY_COMMIT=1f78fed4693a5361f56508daac59bebd5b556379
SRC_URI="https://github.com/koverstreet/bcachefs-tools/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ ${CARGO_CRATE_URIS}"
S="${WORKDIR}/${PN}-${MY_COMMIT}"
KEYWORDS="~amd64"
fi
@@ -129,11 +129,15 @@ src_test() {
}
src_install() {
- exeinto /usr/bin
- local file
- for file in bcachefs fsck.bcachefs mkfs.bcachefs mount.bcachefs; do
- doexe $file
- done
+ into /
+ dosbin bcachefs fsck.bcachefs mkfs.bcachefs mount.bcachefs
+
+ if use fuse; then
+ dosbin mount.fuse.bcachefs
+ newsbin fsck.bcachefs fsck.fuse.bcachefs
+ newsbin mkfs.bcachefs mkfs.fuse.bcachefs
+ fi
+
doman bcachefs.8
}