summaryrefslogtreecommitdiff
path: root/sys-fs/clamfs/clamfs-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-fs/clamfs/clamfs-1.2.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-fs/clamfs/clamfs-1.2.0.ebuild')
-rw-r--r--sys-fs/clamfs/clamfs-1.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/clamfs/clamfs-1.2.0.ebuild b/sys-fs/clamfs/clamfs-1.2.0.ebuild
new file mode 100644
index 000000000000..c7a90b3a7d45
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="https://github.com/burghardt/clamfs"
+SRC_URI="https://github.com/burghardt/clamfs/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/boost-1.33
+ dev-libs/poco
+ dev-libs/rlog
+ sys-fs/fuse:3"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ # Do not use Werror ( #754180 )
+ sed -i 's/\-Werror//g' configure.ac || die "Sed failed"
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}