summaryrefslogtreecommitdiff
path: root/sys-fs/cryptsetup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
commit9bd54251864651f49e673a08aec9ef79cfe08f04 (patch)
treebac28788ab54849c5d28edb190a687167737e736 /sys-fs/cryptsetup
parent6b933047f46efec1aa747570f945344254227457 (diff)
gentoo resync : 17.12.2017
Diffstat (limited to 'sys-fs/cryptsetup')
-rw-r--r--sys-fs/cryptsetup/Manifest3
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild128
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild2
3 files changed, 131 insertions, 2 deletions
diff --git a/sys-fs/cryptsetup/Manifest b/sys-fs/cryptsetup/Manifest
index c9acdb00ac0e..09bd7f3c0ce7 100644
--- a/sys-fs/cryptsetup/Manifest
+++ b/sys-fs/cryptsetup/Manifest
@@ -6,5 +6,6 @@ DIST cryptsetup-1.7.5.tar.xz 1232696 BLAKE2B 1bd62b186564e0b902480d66f623074f8d2
DIST cryptsetup-2.0.0.tar.xz 10079936 BLAKE2B 6e5f1bb20571cf7a66f988e50b2cc88d152a2cd414a9b760ad845cafac3d0aa5b5a1fbd871117b91a78b7cbf1d8a849608221f8a35d1faf26f901518c2d00c6e SHA512 195e9c0b6429d21ec0cc7c5faddfde85cb71eee09d348fa50df6779693a2dc05fce04bada4c835150964e08b2e8af30e4194155e0f6366b24c7812f48477a249
EBUILD cryptsetup-1.7.4.ebuild 4025 BLAKE2B ba5aec9f19bc046e4269baa7d4b73f0e1e0da13253a5ee700fb62cdfaf05de0cb71b86229379d7ce3176e9075e1d063d0f9f488df97da6a8c77e098ef4754f4f SHA512 9b46af09764085af0f6de8e99629839f45b9567110dde94db040e875805ad753f111136da06ffc0a65f3ebd8fa705e0a7509961a24c08032e501967e081f8928
EBUILD cryptsetup-1.7.5.ebuild 4045 BLAKE2B 14036d9f2c6a1eb5b245ff66edd50629b517b632b11bd3303fd47e4ba7b830fec10c6eecf18b7109801e8f5e84ae0104303a9c4adbdcb5de22ce623b527ba82d SHA512 838908ef46db7d9710e9071ec21af4c0243a5b1c5220107522b0145cdb38eb1bc0fde392d276c988cf1b3e14880d4db73b1992e849d416113f01ed05dc0581fd
-EBUILD cryptsetup-2.0.0.ebuild 4315 BLAKE2B c28cac94fa3838471dba585f1ce5e2f48d4bfa9a7570c028632f0305da52719a60a3673b0217e31d8788ef728f3031a036892e3373265d5e71f438a573942c8a SHA512 d2da581f685e429e71fb26a0624866100f1ad49be8b2b8b9ad39063b43036b1916f9de24a59c7e9a5fe29bd75aa401ce02dbcd43e908af9b74b4e051a27536ed
+EBUILD cryptsetup-2.0.0-r1.ebuild 4034 BLAKE2B 0c721b44c70c5efb86a095ed0be33dbd7d08513a0e88013e897671aeab87adc92143b8c8920c366037dbb83f665e6f15414998a743e7b372d0d67570af83e7f6 SHA512 15ccf4858426497aeff2a8fb222139c5ceb4a5ea2396d558342733991cfee53747c88b99f2132ece38b83603bc361d5864728ba0d8bf6860b0ea50c788aa537a
+EBUILD cryptsetup-2.0.0.ebuild 4316 BLAKE2B fa99d5c813a225b3b2a0fcc53694641c6c61178880c652cef8d81f5a63b2145a9dceb60f0f7249b7e4d511cfb0813c7e71553d95ffd03fcdf3d1f532985679ee SHA512 182a0b657627467b0d4d6be85fe0c9ac48232e68c05a42aabee2a1c17bec28eda9bbc082645a6ed8d5a1a1217ca040b62b2d411d0a16a5f9067cdd0fcd638ce0
MISC metadata.xml 974 BLAKE2B 7dc6d2696e918f5a5c195194f70ec053bac4bfc84510234ae63a4bebb8363b72e9b1fcc331312c938839a633c95dae1e88dc24bf8ca0602cefc8bb8ab1c822c0 SHA512 a5c9ab70c75af24d3ffdd076f1eb61c6eec3b388a417f611f8988bf3f2da5daaffaab461b50c995e572d2d800c726ca960e78c3c17dd2a40788fcf48e4158f41
diff --git a/sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..eee71164cf06
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools python-single-r1 linux-info libtool ltprune versionator
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="https://gitlab.com/cryptsetup/cryptsetup/blob/master/README.md"
+SRC_URI="mirror://kernel/linux/utils/${PN}/v$(get_version_component_range 1-2)/${P/_/-}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/12" # libcryptsetup.so version
+[[ ${PV} != *_rc* ]] && \
+KEYWORDS="~amd64 ~arm64 ~mips ~s390 ~sh ~sparc ~x86"
+CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
+# we don't support nss since it doesn't allow cryptsetup to be built statically
+# and it's missing ripemd160 support so it can't provide full backward compatibility
+IUSE="${CRYPTO_BACKENDS} +argon2 libressl nls pwquality python reencrypt static static-libs udev urandom"
+REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ static? ( !gcrypt )" #496612
+
+LIB_DEPEND="
+ dev-libs/json-c[static-libs(+)]
+ dev-libs/libgpg-error[static-libs(+)]
+ dev-libs/popt[static-libs(+)]
+ sys-apps/util-linux[static-libs(+)]
+ argon2? ( app-crypt/argon2[static-libs(+)] )
+ gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
+ nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:=[static-libs(+)] )
+ )
+ pwquality? ( dev-libs/libpwquality[static-libs(+)] )
+ sys-fs/lvm2[static-libs(+)]
+ udev? ( virtual/libudev[static-libs(+)] )"
+# We have to always depend on ${LIB_DEPEND} rather than put behind
+# !static? () because we provide a shared library which links against
+# these other packages. #414665
+RDEPEND="static-libs? ( ${LIB_DEPEND} )
+ ${LIB_DEPEND//\[static-libs\(+\)\]}
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+S="${WORKDIR}/${P/_/-}"
+
+#PATCHES=( )
+
+pkg_setup() {
+ local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC ~CRYPTO_SHA256"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_SHA256="CONFIG_CRYPTO_SHA256:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+}
+
+src_prepare() {
+ sed -i '/^LOOPDEV=/s:$: || exit 0:' tests/{compat,mode}-test || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use kernel ; then
+ ewarn "Note that kernel backend is very slow for this type of operation"
+ ewarn "and is provided mainly for embedded systems wanting to avoid"
+ ewarn "userspace crypto libraries."
+ fi
+
+ use python && python_setup
+
+ # We disable autotool python integration so we can use eclasses
+ # for proper integration with multiple python versions.
+ local myeconfargs=(
+ --disable-internal-argon2
+ --enable-shared
+ --sbindir=/sbin
+ --with-tmpfilesdir="${EPREFIX%/}/usr/lib/tmpfiles.d"
+ --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
+ $(use_enable argon2 libargon2)
+ $(use_enable nls)
+ $(use_enable pwquality)
+ $(use_enable python)
+ $(use_enable reencrypt cryptsetup-reencrypt)
+ $(use_enable static static-cryptsetup)
+ $(use_enable static-libs static)
+ $(use_enable udev)
+ $(use_enable !urandom dev-random)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if [[ ! -e /dev/mapper/control ]] ; then
+ ewarn "No /dev/mapper/control found -- skipping tests"
+ return 0
+ fi
+
+ local p
+ for p in /dev/mapper /dev/loop* ; do
+ addwrite ${p}
+ done
+
+ default
+}
+
+src_install() {
+ default
+
+ if use static ; then
+ mv "${ED%}"/sbin/cryptsetup{.static,} || die
+ mv "${ED%}"/sbin/veritysetup{.static,} || die
+ use reencrypt && { mv "${ED%}"/sbin/cryptsetup-reencrypt{.static,} || die ; }
+ fi
+ prune_libtool_files --modules
+
+ dodoc docs/v*ReleaseNotes
+
+ newconfd "${FILESDIR}"/1.6.7-dmcrypt.confd dmcrypt
+ newinitd "${FILESDIR}"/1.6.7-dmcrypt.rc dmcrypt
+}
diff --git a/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild
index ecdf5fbd105f..3d7adacf8e2b 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~arm64 ~mips ~s390 ~sh ~sparc ~x86"
CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
-IUSE="${CRYPTO_BACKENDS} argon2 libressl nls pwquality python reencrypt static static-libs udev urandom"
+IUSE="${CRYPTO_BACKENDS} +argon2 libressl nls pwquality python reencrypt static static-libs udev urandom"
REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
python? ( ${PYTHON_REQUIRED_USE} )
static? ( !gcrypt )" #496612