summaryrefslogtreecommitdiff
path: root/sys-fs/dislocker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/dislocker
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/dislocker')
-rw-r--r--sys-fs/dislocker/Manifest5
-rw-r--r--sys-fs/dislocker/dislocker-0.7.1-r1.ebuild47
-rw-r--r--sys-fs/dislocker/dislocker-9999.ebuild47
-rw-r--r--sys-fs/dislocker/metadata.xml11
4 files changed, 110 insertions, 0 deletions
diff --git a/sys-fs/dislocker/Manifest b/sys-fs/dislocker/Manifest
new file mode 100644
index 000000000000..25f775e3e6e5
--- /dev/null
+++ b/sys-fs/dislocker/Manifest
@@ -0,0 +1,5 @@
+DIST dislocker-0.7.1.tar.gz 103194 SHA256 742fb5c1b3ff540368ced54c29eae8b488ae5a5fcaca092947e17c2d358a6762 SHA512 8852ba3e363fdea992eebecfe1e4dad2b85404f57c57ce6b2937a9859d03cfa88d969926c9e11e6d22596c6d96805b7d1737893ae2c5a957448ab26708bce226 WHIRLPOOL 1f8b8769cac08be4df70c953f967c8408d44b34ebc8e7b0b09e400b827e01234b467990ca0f2cee80518cdea63fbf40cadc75faf4caacd723226a27ee6978fe6
+EBUILD dislocker-0.7.1-r1.ebuild 1190 SHA256 1ae95bb6c27c7c95448bb57acc1bf04dfe888727fa289d745585a929c99e5ec9 SHA512 8a3507ab0641fb0dbbcbfd968e2c9a45531533485a0d38d079975bdcaec1e4ec3228373e6f1600e5195b944534c342015ec684b4815b6adc5c8dd4b04a2f00dd WHIRLPOOL 70708857a6157dd94293af1835b86ed2e183477d2d3b39fc0cfd19bbb3ad7cf7376622b6871eb0b2d5f2158829e342a4c1168f21b022fdd687cb86a25becc9ae
+EBUILD dislocker-9999.ebuild 1190 SHA256 1ae95bb6c27c7c95448bb57acc1bf04dfe888727fa289d745585a929c99e5ec9 SHA512 8a3507ab0641fb0dbbcbfd968e2c9a45531533485a0d38d079975bdcaec1e4ec3228373e6f1600e5195b944534c342015ec684b4815b6adc5c8dd4b04a2f00dd WHIRLPOOL 70708857a6157dd94293af1835b86ed2e183477d2d3b39fc0cfd19bbb3ad7cf7376622b6871eb0b2d5f2158829e342a4c1168f21b022fdd687cb86a25becc9ae
+MISC ChangeLog 1235 SHA256 9a3cab004a19b94da391c99f1b630204d4d0c091636146376a3cf25ce4e3c535 SHA512 5ea9ed0c0cc776369d72f0cabb456f7ba76764ba7f6eeaf17d3969f2ccb13a2d34d293248f02ef5c4016d1ffad44e517742d03cf5389b91b185abc064d6055a0 WHIRLPOOL cf133bf6ae4fc9e8135aafa4712da88a6feb67ac66da0b26ff9f2498a92b6cabb0c46cd66709f41b3cb62a4225f003d2021722bc6a406b2fee65fad9631681d7
+MISC metadata.xml 343 SHA256 ea2f5b27ddce5b54eafbbcded86777bca6b4fe11c64fc8a2811b490b9129ab2c SHA512 479da4294232d9c49530e2ed2c936c824c697b08d722309addb64bc77dd083365b0d4ce063dd331e4dbd13a0185885dca7bf5d62a6a09dfc6e7a38fd7e25f448 WHIRLPOOL d588216ea963e9caf2d03adf2ebeb48135ebb4f082f1a9c32ef9d656506c25803e295f1b18be37a7cca84ecc21142e0ed897ee993c22412041a95b9d6640774e
diff --git a/sys-fs/dislocker/dislocker-0.7.1-r1.ebuild b/sys-fs/dislocker/dislocker-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..f0bc602be4d9
--- /dev/null
+++ b/sys-fs/dislocker/dislocker-0.7.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
+HOMEPAGE="https://github.com/Aorimn/dislocker"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ruby"
+
+DEPEND="sys-fs/fuse:*
+ net-libs/mbedtls
+ ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.3 ) )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
+# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
+ sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
+
+ sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_find_package ruby Ruby)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ find "${S}/man/linux" -name '*.1' -exec doman '{}' +
+ cmake-utils_src_install
+}
diff --git a/sys-fs/dislocker/dislocker-9999.ebuild b/sys-fs/dislocker/dislocker-9999.ebuild
new file mode 100644
index 000000000000..f0bc602be4d9
--- /dev/null
+++ b/sys-fs/dislocker/dislocker-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
+HOMEPAGE="https://github.com/Aorimn/dislocker"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ruby"
+
+DEPEND="sys-fs/fuse:*
+ net-libs/mbedtls
+ ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.3 ) )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
+# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
+ sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
+
+ sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_find_package ruby Ruby)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ find "${S}/man/linux" -name '*.1' -exec doman '{}' +
+ cmake-utils_src_install
+}
diff --git a/sys-fs/dislocker/metadata.xml b/sys-fs/dislocker/metadata.xml
new file mode 100644
index 000000000000..9cc82876f8af
--- /dev/null
+++ b/sys-fs/dislocker/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nativemad@gentoo.org</email>
+ <name>Andreas Schuerch</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aorimn/dislocker</remote-id>
+ </upstream>
+</pkgmetadata>