summaryrefslogtreecommitdiff
path: root/sys-fs/fatcat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-fs/fatcat
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-fs/fatcat')
-rw-r--r--sys-fs/fatcat/Manifest2
-rw-r--r--sys-fs/fatcat/fatcat-1.1.0-r1.ebuild26
-rw-r--r--sys-fs/fatcat/files/fatcat-include-getopt.patch11
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/fatcat/Manifest b/sys-fs/fatcat/Manifest
index b4cc11d73bc4..bf665087600c 100644
--- a/sys-fs/fatcat/Manifest
+++ b/sys-fs/fatcat/Manifest
@@ -1,5 +1,7 @@
+AUX fatcat-include-getopt.patch 268 BLAKE2B f197d14653e3c738bc096fe1f2865794e1cedffe87c49d62e769b542f6ff85caf2e8079cf17204010d4e5c5438c8df92c12aa780bfbdafb9bdbcd66b994c499b SHA512 71b6970aea57969099deba84bc1c7ad6aca025841140bdcb569d0e2b8f083618022eac84895522c33dc6f5e53bcccb0b21d380eed1ebb251928f17e08486315b
DIST fatcat-1.0.6.tar.gz 50447 BLAKE2B f33c479ec9482a7cf7113d1fa0d02c8bde0c58c5162e392867c18ec157f23d9891e90c9571892fe48b22b5c6d713404bdbd822ac07f4bba9243fcb1ead6932c3 SHA512 5a0eedad9c3d3f8dc6d7230c74669082a33850bd0a91310dccb080f4a2351ca75be6af7bbb6610c71030d5f97cf63f98f43891084171a82e07ef70064a8bce7b
DIST fatcat-1.1.0.tar.gz 57104 BLAKE2B 9ff69f576258a39b767db67e6934a35175af218a184516681300c646ce1ec508652cf1113bf61f9e2f628849de2b53152345ca12fe84e8a9a7f51799bb3e13a2 SHA512 f5bcffcb46b77e950241a9f957133083ea5d43f4e0f3e038c84310da926cc017048d22f85f3c8e90a2745ce26f513079997717c5b758649b7090694006be0078
EBUILD fatcat-1.0.6.ebuild 468 BLAKE2B f99c0b10c95dd3c3cbda988286e3bdad2152c4c95962b780f2d9cdcb00031b12acb69d6450ec25c737faabd1711a419a6e546b2340956b4815faf4cf0d3a7dd6 SHA512 5571b2b8d9dd87e16f0e9abee2b9f5524c5c47ab9cb9be661abec684387df16d96cedbb1b22d68476d749caefe88ef8026675419b9032012e61bacebe4427d13
+EBUILD fatcat-1.1.0-r1.ebuild 597 BLAKE2B e2ec5300b4f92ebf71922b5c5a3977347fa1a6497d10f7758f41d7cef1b83f70d8844e9c240d15bc95deb413cfb6e394487d0e887f2b68511161122edff59ef7 SHA512 bf0ae51c6015d4d9bbf5ab75c2f3bed230c922d889aeb0d24f7ad597e6f78cf32a73c357c5152d4b896d3b9f059442a2424c2a7e07f7d8d66b0912dc5261bc1a
EBUILD fatcat-1.1.0.ebuild 469 BLAKE2B 48a6760ee0b46d4cdd1bf58abc03ea5bb6924848855607b980b1e7f965e15677ed204e3f6f4b8df58797d369dddd91ba9459ac29d884d2930e9d187cb2bd221c SHA512 fdbc251d0e0686ec61b3f929c790f79e2308e1b0141846712122425225de7eab154dc49c3edb83c3d375a35cb535a97f8cd91958fcb11249e8dfe0b532020263
MISC metadata.xml 240 BLAKE2B 5caea4abbcf161615353b1f5ec499ae37ae67f08f6f1d48829d145694359169508d62173c091700e9a65d8ed461216caf12cc6728760784aa364d610250369ca SHA512 ee5c2cad860daff025c5d2bbc7e210767432dd09d1a74fc7b1d5994686d48739b9bfd446bf1ab7b1b92532f82767e722ea3e38d7a502a7a941f6ac5028000ce8
diff --git a/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3fd6f3130447
--- /dev/null
+++ b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="FAT filesystems explore, extract, repair, and forensic tool"
+HOMEPAGE="https://github.com/Gregwar/fatcat"
+SRC_URI="https://github.com/Gregwar/fatcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!elibc_glibc? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fatcat-include-getopt.patch )
+
+src_install() {
+ cmake-utils_src_install
+ doman man/${PN}.1
+ dodoc docs/*.md
+}
diff --git a/sys-fs/fatcat/files/fatcat-include-getopt.patch b/sys-fs/fatcat/files/fatcat-include-getopt.patch
new file mode 100644
index 000000000000..a9c9094eceb3
--- /dev/null
+++ b/sys-fs/fatcat/files/fatcat-include-getopt.patch
@@ -0,0 +1,11 @@
+diff -ur a/src/fatcat.cpp b/src/fatcat.cpp
+--- a/src/fatcat.cpp 2020-04-05 11:12:55.773602065 -0500
++++ b/src/fatcat.cpp 2020-04-05 11:13:14.112132604 -0500
+@@ -8,6 +8,7 @@
+ #include "xgetopt/xgetopt.h"
+ #else
+ #include <argp.h>
++#include <getopt.h>
+ #endif
+ #endif
+