summaryrefslogtreecommitdiff
path: root/sys-fs/fragview/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /sys-fs/fragview/files
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'sys-fs/fragview/files')
-rw-r--r--sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch b/sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch
new file mode 100644
index 000000000000..2eadf02bfff7
--- /dev/null
+++ b/sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch
@@ -0,0 +1,46 @@
+From 11ab3027fda015798b92fd7e44cb5e3289f41542 Mon Sep 17 00:00:00 2001
+From: Rinat <ibragimovrinat@mail.ru>
+Date: Thu, 18 Jul 2013 12:03:30 +0400
+Subject: [PATCH] fix linking with "-Wl,--as-needed"
+
+https://github.com/i-rinat/fragview/issues/2
+
+
+https://github.com/i-rinat/fragview/commit/11ab3027fda015798b92fd7e44cb5e3289f41542
+
+
+---
+ CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d7003e4..fbd7cbb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -43,13 +43,13 @@ add_executable (fileseverity
+ )
+
+ target_link_libraries (fragview
+- ${GTKMM_LIBRARIES}
+ clusters
++ ${GTKMM_LIBRARIES}
+ )
+
+ target_link_libraries (fileseverity
+- ${GLIBMM_LIBRARIES}
+ clusters
++ ${GLIBMM_LIBRARIES}
+ )
+
+ add_executable (fragdb
+@@ -57,9 +57,9 @@ add_executable (fragdb
+ )
+
+ target_link_libraries (fragdb
++ clusters
+ ${GLIBMM_LIBRARIES}
+ ${SQLITE3_LIBRARIES}
+- clusters
+ )
+
+ install (TARGETS fileseverity fragdb fragview