summaryrefslogtreecommitdiff
path: root/sys-fs/go-mtpfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/go-mtpfs
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/go-mtpfs')
-rw-r--r--sys-fs/go-mtpfs/Manifest4
-rw-r--r--sys-fs/go-mtpfs/go-mtpfs-9999.ebuild48
-rw-r--r--sys-fs/go-mtpfs/metadata.xml11
3 files changed, 63 insertions, 0 deletions
diff --git a/sys-fs/go-mtpfs/Manifest b/sys-fs/go-mtpfs/Manifest
new file mode 100644
index 000000000000..eeb321b61d3b
--- /dev/null
+++ b/sys-fs/go-mtpfs/Manifest
@@ -0,0 +1,4 @@
+EBUILD go-mtpfs-9999.ebuild 1062 SHA256 02abf4d83c95b8a1c9eee27cde4c11aeae0cb6e3e5efa928138e65fc87d39878 SHA512 4865c4c9d0c3e62cc9e4aef2b071e823385842228b5626dd474357e9f9dec9738243c5d25e326235904c0f23bfa49a45db7ec5a502549fc0ce73b1bb060cc284 WHIRLPOOL 49e400f6d21800b4c024e3c98a75ede52ab2c3206854f7d318de434e3cb82929d77d276536a086ced8c0112524fae86d42a534d93c17a6800c94d407946a799f
+MISC ChangeLog 2175 SHA256 15dd638d14a1dffc3d51e079323d5d8c162d879186a7f719e9950bcf578b0cd1 SHA512 db6f7285c575742bd5237ca2d000c0c691e7710a3ec510bf37daef6e92464da41fb7875f849db9b06027008bafe72ae04dbea83253479235df186ca756ae1578 WHIRLPOOL 5e6800ebe999a0c85bd8aa04e37d098074fa80e9f0b03d2766b60366d74a058270c93850a1927ac8ec85539834c6aeb030d9751b602f0c04ab392088743bdc1e
+MISC ChangeLog-2015 1090 SHA256 0fe4bbd8ba75dfe7c82ed9b69a4034afb22129d9345430627cc5e9d2164b905d SHA512 92cd0ce54ccc431a5dfa99f2226c6d6f36e662e4a74b0ce4c906a1b1d4ddc5fbebe8f488b210ea88205767c203156824f48e17c649f057189b06a35190592701 WHIRLPOOL 577a01b63307a03de3eaa78ad08f1fa2fb53f9baa87b19c3c0dd95c9b6a24c0f1a681ddb998110701a1d1d79bf2872a306c02f21131e6c970822412d6c00dbb4
+MISC metadata.xml 327 SHA256 1f4fe14d985361cb656e150337e913eb75844764f95f2d1202701a884a146c77 SHA512 a8debf10dfbec6f73b80abede368c00dd5d20f319edc28ae5264400fe4916c9a4150c134a68757e007d309222f2051ce66cb36d12be181f7d65e954725db2d66 WHIRLPOOL 83792277a87a4c5dc2a8b15f5e4155127e7d3c2b154cf0906996b7a3655336a728be7e6f694eab99ec1725ecf767f709ce52d9b8a6ae100bcd00e3ad63711d32
diff --git a/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
new file mode 100644
index 000000000000..79178eb3ff39
--- /dev/null
+++ b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit git-r3 flag-o-matic toolchain-funcs
+
+DESCRIPTION="a simple FUSE filesystem for mounting Android devices as a MTP device"
+HOMEPAGE="https://github.com/hanwen/go-mtpfs"
+EGIT_REPO_URI="https://github.com/hanwen/go-mtpfs.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEPEND="virtual/libusb
+ virtual/udev"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/go-fuse
+ dev-libs/go-usb
+ dev-lang/go
+ media-libs/libmtp"
+
+RDEPEND="${COMMON_DEPEND}"
+
+#Tests require a connected mtp device
+RESTRICT="test"
+
+GO_PN="github.com/hanwen/${PN}"
+EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+QA_FLAGS_IGNORED=usr/bin/go-mtpfs
+
+export GOPATH="${S}"
+
+src_compile() {
+ go build -ldflags '-extldflags=-fno-PIC' -v -x -work ${GO_PN} || die
+}
+
+src_test() {
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/fs || die
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/usb || die
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN}/mtp || die
+}
+
+src_install() {
+ dobin go-mtpfs
+}
diff --git a/sys-fs/go-mtpfs/metadata.xml b/sys-fs/go-mtpfs/metadata.xml
new file mode 100644
index 000000000000..dc1d6c77a19c
--- /dev/null
+++ b/sys-fs/go-mtpfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hanwen/go-mtpfs</remote-id>
+ </upstream>
+</pkgmetadata>