summaryrefslogtreecommitdiff
path: root/sys-fs/libeatmydata/libeatmydata-105-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /sys-fs/libeatmydata/libeatmydata-105-r2.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'sys-fs/libeatmydata/libeatmydata-105-r2.ebuild')
-rw-r--r--sys-fs/libeatmydata/libeatmydata-105-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/libeatmydata/libeatmydata-105-r2.ebuild b/sys-fs/libeatmydata/libeatmydata-105-r2.ebuild
new file mode 100644
index 000000000000..2b6e0ab0a184
--- /dev/null
+++ b/sys-fs/libeatmydata/libeatmydata-105-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="LD_PRELOAD hack to convert sync()/msync() and the like to NO-OP"
+HOMEPAGE="https://launchpad.net/libeatmydata/"
+SRC_URI="https://launchpad.net/${PN}/trunk/release-${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# sandbox fools LD_PRELOAD and libeatmydata does not get control
+# feature of sandbox
+#DEPEND="test? ( dev-util/strace )"
+RESTRICT=test
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-105-undpkg.patch
+)
+
+ECONF_SOURCE=${S}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -type f -delete || die
+
+ dodoc AUTHORS README
+}