summaryrefslogtreecommitdiff
path: root/sys-fs/lxcfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
commita519cf56a0e5e456006d39c06f68de5e11c2f7e9 (patch)
treeeb3511664a62de4a02ec7f25a9a3935956e288ab /sys-fs/lxcfs
parentd63d16d19ab9b58260753953a431d39230f2c362 (diff)
gentoo auto-resync : 07:10:2023 - 12:00:01
Diffstat (limited to 'sys-fs/lxcfs')
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/lxcfs-5.0.4.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index e0c569ae57fa..4b8ccfdfe22a 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -5,5 +5,4 @@ AUX lxcfs-5.0.4-fix-incompatible-pointer-conversion.patch 662 BLAKE2B 63ef53897c
DIST lxcfs-5.0.4.tar.gz 104249 BLAKE2B 83a7b861136c34da8a24dd525fd0767193f2bbd92b40e3b9fd5e42d7645465411792e65e95797ab13b33330299d12b19bdd5786352875ed88ac0097b72b711a9 SHA512 b404045dbabe23e1d1f1d74c1648d2596bb70aaa9f9e46f9f5635b0a02d0c451f68b2559920bbefc5b889e908cf1da0a33c148b26bdce3e45c3d0cbdff710604
DIST lxcfs-5.0.4.tar.gz.asc 833 BLAKE2B aff883d24b374b296ea3678670e5e82c723fd0e35cfd7fed555aabbd811a104becc0b741331b4aa4a5129c9fff4dc88c6a86e7d64a89fe86aea81718f5d432dd SHA512 56b639597dbaf3008fe030147ea37192bd465c467a79e11ce139bcaa6bca1625b4bb9c4eda6ea1877446769f0fad9b4c5a3513d4f4415b841db96d5da8325ddc
EBUILD lxcfs-5.0.4-r1.ebuild 1990 BLAKE2B 248e2568957341110f44c6b06a35ac741fc4395527954313fc8aa1fbced1d5708343a8a9e35eb5edff55d50395f63dedc4f51238e3d8d4183b1d70ad972781b7 SHA512 0fbb69ef7b52bb8c69b92211e581c3e02b1cd6840586d389d38fe7ec3eb2c9582820b40f30fb6574846fc60a26d5cd4d4611c34a3994c0393aea48a147583495
-EBUILD lxcfs-5.0.4.ebuild 1907 BLAKE2B f23b2c9a9d9d3e59aef24e99f5b6ba7d72c8fd0166ca468de4c1d0fbc80c594fb8a293e3df5d8fbfdc25e7afa71700c6c0321ee630e25e4befcc3dbdf58fc89a SHA512 d9e5abde77b561707b442eb002017f08cfac40688e644b7a1e6a53c5122ebaaf6711d36424e8b5c529fd36b552406adaf7b282c4836516aac05cb1cb8bdc3f43
MISC metadata.xml 710 BLAKE2B ac2111d3b67e2aa7286b98e3069e77e3b852f401b56a921795370febd8836434e13cfec4af92cc83a379037023c3d7af475516bea02545595fe9a58a188dcb2f SHA512 f07ff1acbf28cda31d9d962332ecf473197d2868488e7051185ab5ab792f5bb9405712d68e3f9c3b10f38024d2025784b98ce9513e2978f537c26bc7c4d7caab
diff --git a/sys-fs/lxcfs/lxcfs-5.0.4.ebuild b/sys-fs/lxcfs/lxcfs-5.0.4.ebuild
deleted file mode 100644
index cf1c6ee0cb54..000000000000
--- a/sys-fs/lxcfs/lxcfs-5.0.4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..12} )
-
-inherit cmake meson python-any-r1 systemd verify-sig
-
-DESCRIPTION="FUSE filesystem for LXC"
-HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
-SRC_URI="https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz
- verify-sig? ( https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz.asc )"
-
-LICENSE="Apache-2.0 LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv ~x86"
-IUSE="doc test"
-
-DEPEND="sys-fs/fuse:3"
-RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}
- virtual/pkgconfig
- $(python_gen_any_dep '
- dev-python/jinja[${PYTHON_USEDEP}]
- ')
- doc? ( sys-apps/help2man )
- verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
-
-# Needs some black magic to work inside container/chroot.
-RESTRICT="test"
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
-
-python_check_deps() {
- python_has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Fix python shebangs for python-exec[-native-symlinks], #851480
- local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
- python_fix_shebang -q ${shebangs[*]}
-}
-
-src_configure() {
- local emesonargs=(
- --localstatedir "${EPREFIX}/var"
-
- $(meson_use doc docs)
- $(meson_use test tests)
-
- -Dfuse-version=3
- -Dinit-script=""
- -Dwith-init-script=""
- )
-
- meson_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}"/tests || die "failed to change into tests/ directory."
- ./main.sh || die
-}
-
-src_install() {
- meson_src_install
-
- newconfd "${FILESDIR}"/lxcfs-5.0.2.confd lxcfs
- newinitd "${FILESDIR}"/lxcfs-5.0.2.initd lxcfs
-
- # Provide our own service file (copy of upstream) due to paths being different from upstream,
- # #728470
- systemd_newunit "${FILESDIR}"/lxcfs-5.0.2.service lxcfs.service
-}