summaryrefslogtreecommitdiff
path: root/sys-fs/mount-zip/mount-zip-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /sys-fs/mount-zip/mount-zip-1.0.10.ebuild
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'sys-fs/mount-zip/mount-zip-1.0.10.ebuild')
-rw-r--r--sys-fs/mount-zip/mount-zip-1.0.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/mount-zip/mount-zip-1.0.10.ebuild b/sys-fs/mount-zip/mount-zip-1.0.10.ebuild
new file mode 100644
index 000000000000..99491ac26198
--- /dev/null
+++ b/sys-fs/mount-zip/mount-zip-1.0.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="FUSE file system for ZIP archives"
+HOMEPAGE="https://github.com/google/mount-zip"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/libzip:=
+ sys-fs/fuse:0=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DOCS=( changelog README.md )
+
+src_install() {
+ default
+ doman mount-zip.1
+}